summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2022-12-06 07:56:51 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2022-12-06 07:59:00 +0100
commit6834a0595575be8645382b8c709f316cb1550633 (patch)
treedf45cac1036a13753f47b9e4659f01f14e95fb25 /media-radio
parentdev-vcs/git: add 2.39.0_rc2, drop 2.39.0_rc1 (diff)
downloadgentoo-6834a0595575be8645382b8c709f316cb1550633.tar.gz
gentoo-6834a0595575be8645382b8c709f316cb1550633.tar.bz2
gentoo-6834a0595575be8645382b8c709f316cb1550633.zip
media-radio/grig: Adapt to Hamlib4.5
Closes: https://bugs.gentoo.org/883773 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/grig/files/grig-0.8.1-hamlib45.patch17
-rw-r--r--media-radio/grig/grig-0.8.1-r1.ebuild7
2 files changed, 21 insertions, 3 deletions
diff --git a/media-radio/grig/files/grig-0.8.1-hamlib45.patch b/media-radio/grig/files/grig-0.8.1-hamlib45.patch
new file mode 100644
index 000000000000..4da0a6496978
--- /dev/null
+++ b/media-radio/grig/files/grig-0.8.1-hamlib45.patch
@@ -0,0 +1,17 @@
+Hamlib 4.5 dropped rig_get_split macro
+see Bug 883773
+
+diff --git a/src/rig-daemon.c b/src/rig-daemon.c
+index ddd922f..1a86a5e 100644
+--- a/src/rig-daemon.c
++++ b/src/rig-daemon.c
+@@ -2283,7 +2283,8 @@ rig_daemon_exec_cmd (rig_cmd_t cmd,
+ case RIG_CMD_GET_SPLIT:
+ if (has_get->split) {
+
+- retcode = rig_get_split (myrig, RIG_VFO_RX, &get->split);
++ vfo_t tx_vfo;
++ retcode = rig_get_split_vfo (myrig, RIG_VFO_RX, &get->split, &tx_vfo);
+
+ /* raise anomaly if execution did not succeed */
+ if (retcode != RIG_OK) {
diff --git a/media-radio/grig/grig-0.8.1-r1.ebuild b/media-radio/grig/grig-0.8.1-r1.ebuild
index 07f9ee0da9ba..f4a97bae6a70 100644
--- a/media-radio/grig/grig-0.8.1-r1.ebuild
+++ b/media-radio/grig/grig-0.8.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,7 +20,8 @@ DEPEND="
>=media-libs/hamlib-4:="
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}"/grig-0.8.1-hamlib4.patch )
+PATCHES=( "${FILESDIR}"/grig-0.8.1-hamlib4.patch
+ "${FILESDIR}"/grig-0.8.1-hamlib45.patch )
src_configure() {
econf --enable-hardware
@@ -32,7 +33,7 @@ src_prepare() {
eapply -p1 "${FILESDIR}"/${P}-hamlib42.patch
fi
- eapply ${PATCHES}
+ eapply ${PATCHES[@]}
eapply_user
}