summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-06-19 10:24:32 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-06-19 10:24:32 +0200
commit1f2f15ef2177725914831748d7355e19c016d15d (patch)
tree462c0d919f111333f1fff7a9eaf1b124cdd5f665 /media-sound/cmusfm/cmusfm-0.4.0.ebuild
parentmedia-sound/yoshimi: bump to 2.0.2 (diff)
downloadgentoo-1f2f15ef2177725914831748d7355e19c016d15d.tar.gz
gentoo-1f2f15ef2177725914831748d7355e19c016d15d.tar.bz2
gentoo-1f2f15ef2177725914831748d7355e19c016d15d.zip
media-sound/cmusfm: bump to 0.4.0, dropped 0.3.3 due to api change
Closes: https://bugs.gentoo.org/792447 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/cmusfm/cmusfm-0.4.0.ebuild')
-rw-r--r--media-sound/cmusfm/cmusfm-0.4.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/cmusfm/cmusfm-0.4.0.ebuild b/media-sound/cmusfm/cmusfm-0.4.0.ebuild
new file mode 100644
index 000000000000..b2cac96f9c33
--- /dev/null
+++ b/media-sound/cmusfm/cmusfm-0.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools readme.gentoo-r1
+
+DESCRIPTION="Last.fm scrobbler for cmus music player"
+HOMEPAGE="https://github.com/Arkq/cmusfm"
+SRC_URI="https://github.com/Arkq/cmusfm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+DEPEND="
+ net-misc/curl
+ dev-libs/openssl:0=
+ libnotify? ( x11-libs/libnotify )
+"
+RDEPEND="
+ ${DEPEND}
+ media-sound/cmus
+"
+BDEPEND="virtual/pkgconfig"
+
+DOC_CONTENTS="Please refer to the README.md file before running cmusfm the first time."
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable libnotify)
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+}