summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/flac-image
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/flac-image')
-rw-r--r--media-sound/flac-image/Manifest1
-rw-r--r--media-sound/flac-image/flac-image-1.00.ebuild43
-rw-r--r--media-sound/flac-image/metadata.xml10
3 files changed, 54 insertions, 0 deletions
diff --git a/media-sound/flac-image/Manifest b/media-sound/flac-image/Manifest
new file mode 100644
index 000000000000..1af5b8b4b15e
--- /dev/null
+++ b/media-sound/flac-image/Manifest
@@ -0,0 +1 @@
+DIST flac-image-1.00.tar.gz 13948 SHA256 c4ee58d7f447a2a48b12b338682ddca4d9e7630e1dd04cc5e6e190b8a5ce7109 SHA512 71d72a240c0f156b546310bf356f3304bf04152317df683e30205ae79d8b97fe2a29d63e3fdea5b21d0a62390459527ecf33f6d509b36196a8dc0e28cd1a3e1d WHIRLPOOL 4b7f2e8fd42dcf6e7d38a5b4055f869078ce415065a7a297930dcecf0b9c1ea27638f4a49de9dde467854687b5595bb4f4d7a36f335a6894547a2b27d1c138f0
diff --git a/media-sound/flac-image/flac-image-1.00.ebuild b/media-sound/flac-image/flac-image-1.00.ebuild
new file mode 100644
index 000000000000..fca1550ca70e
--- /dev/null
+++ b/media-sound/flac-image/flac-image-1.00.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Utility for stuffing image files (e.g. album cover art) into metadata blocks in FLAC files"
+HOMEPAGE="http://www.singingtree.com/software/"
+SRC_URI="http://www.singingtree.com/software/${PN}.tar.gz -> ${P}.tar.gz"
+# FIXME: no version in tarball, but also no updates for a long time. So it's ok.
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/flac"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+# compile helper
+_compile() {
+ local CC="$(tc-getCC)"
+ echo "${CC} ${@}" && "${CC}" "${@}"
+}
+
+src_prepare() {
+ sed -i -e "s:^\(#include <stdio.h>\):\1\n#include <string.h>:g" "${PN}.c"
+ rm -f -- "${PN}" # remove pre-compiled binary
+}
+
+src_compile() {
+ # Makefile is both simple and broken, so we compile the binary ourself.
+ _compile ${CFLAGS} ${LDFLAGS} -o "${PN}" "${PN}.c" -lFLAC \
+ || die "compile failed"
+}
+
+src_install() {
+ dobin "${PN}"
+}
diff --git a/media-sound/flac-image/metadata.xml b/media-sound/flac-image/metadata.xml
new file mode 100644
index 000000000000..b1cf7fe492bb
--- /dev/null
+++ b/media-sound/flac-image/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <longdescription lang="en">
+ A tiny utility for stuffing image files (e.g. album cover art) into
+ metadata blocks in FLAC files. Actually you could store and retrieve
+ any arbitrary file you wanted; this program doesn't care.
+ </longdescription>
+</pkgmetadata>