summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2015-10-31 15:07:20 +0100
committerIan Delaney <idella4@gentoo.org>2015-11-11 12:04:09 +0800
commit08f0618fc84f1d1c8b0011a7460d37fd1b1d924c (patch)
tree78d334189e0f29a91a29271c8424bd0afe744293 /media-sound/frescobaldi/frescobaldi-2.18.1.ebuild
parentdev-python/python-ly: initial commit (diff)
downloadgentoo-08f0618fc84f1d1c8b0011a7460d37fd1b1d924c.tar.gz
gentoo-08f0618fc84f1d1c8b0011a7460d37fd1b1d924c.tar.bz2
gentoo-08f0618fc84f1d1c8b0011a7460d37fd1b1d924c.zip
media-sound/frescobaldi: version bump to 2.18.1, depend on python-ly wrt #543052, #561022
Package-Manager: portage-2.2.23
Diffstat (limited to 'media-sound/frescobaldi/frescobaldi-2.18.1.ebuild')
-rw-r--r--media-sound/frescobaldi/frescobaldi-2.18.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/frescobaldi/frescobaldi-2.18.1.ebuild b/media-sound/frescobaldi/frescobaldi-2.18.1.ebuild
new file mode 100644
index 000000000000..86e030f276b8
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-2.18.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="http://www.frescobaldi.org/"
+SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 public-domain" # public-domain is for bundled Tango icons
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portmidi"
+
+RDEPEND="dev-python/python-poppler-qt4[${PYTHON_USEDEP}]
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ >=dev-python/python-ly-0.9[${PYTHON_USEDEP}]
+ >=media-sound/lilypond-2.14.2
+ portmidi? ( media-libs/portmidi[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}