summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-08 06:53:00 +0100
committerSam James <sam@gentoo.org>2024-04-08 06:53:00 +0100
commita22d989510ab5f2ddac94e8089a68b93540c13b1 (patch)
tree977ee4c2dd66db58198877ed40ab3b7973ff32ac /media-sound/grip
parentmedia-sound/cdparanoia: EAPI 8, add pkg-config file (diff)
downloadgentoo-a22d989510ab5f2ddac94e8089a68b93540c13b1.tar.gz
gentoo-a22d989510ab5f2ddac94e8089a68b93540c13b1.tar.bz2
gentoo-a22d989510ab5f2ddac94e8089a68b93540c13b1.zip
media-sound/grip: switch to Meson
Needs b935417e4654d43e89c5f8b08e67bac113afbeba for cdparanoia. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/grip')
-rw-r--r--media-sound/grip/grip-4.2.4-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/grip/grip-4.2.4-r1.ebuild b/media-sound/grip/grip-4.2.4-r1.ebuild
new file mode 100644
index 000000000000..4fbf071b1b10
--- /dev/null
+++ b/media-sound/grip/grip-4.2.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper"
+HOMEPAGE="https://sourceforge.net/projects/grip/"
+SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="vorbis"
+
+# lame and vorbis-tools are no real RDEPENDs. But without them
+# grip cannot convert ripped files to any format. So use them as
+# a sane default.
+RDEPEND="
+ !app-text/grip
+ dev-libs/glib:2
+ media-libs/id3lib
+ >=media-sound/cdparanoia-3.10.2-r8
+ media-sound/lame
+ net-misc/curl
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ vorbis? ( media-sound/vorbis-tools )
+"
+# gnome-extra/yelp, see bug #416843
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dcdparanoia=enabled
+ -Did3lib=enabled
+ )
+
+ meson_src_configure
+}