summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/lastfm-desktop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/lastfm-desktop')
-rw-r--r--media-sound/lastfm-desktop/Manifest2
-rw-r--r--media-sound/lastfm-desktop/files/lastfm-desktop-2.1.36-missing-cast.patch25
-rw-r--r--media-sound/lastfm-desktop/lastfm-desktop-2.1.35.ebuild32
-rw-r--r--media-sound/lastfm-desktop/lastfm-desktop-2.1.36.ebuild34
-rw-r--r--media-sound/lastfm-desktop/metadata.xml10
5 files changed, 103 insertions, 0 deletions
diff --git a/media-sound/lastfm-desktop/Manifest b/media-sound/lastfm-desktop/Manifest
new file mode 100644
index 000000000000..68ae7dd21a34
--- /dev/null
+++ b/media-sound/lastfm-desktop/Manifest
@@ -0,0 +1,2 @@
+DIST lastfm-desktop-2.1.35.tar.gz 6789600 SHA256 2f96f0bc66c8b87dc3ca7858ef756f1ec4c84eb70eb1c411f840af51830a3075 SHA512 9eb4f750b344b788195b6800dc6fb6962449bcfc8cb2933a5065eb6f45e7d1de0463c7c091da3001a5e09dc116939aa4cf8918138bd749ba8c06c6ceca01684a WHIRLPOOL 5cc85733e8f2f08698aa0e8f124dc55a9ef00beb579e79b2569f14d6aef1ced7c149027353cff38ceaccbfddaf7b6677091b5e489fae24667cab5cb100cfeee2
+DIST lastfm-desktop-2.1.36.tar.gz 4087375 SHA256 2c33e8b8d6442da768bad3fb96e52a67ee17e3e64c5899ad81a893075635b969 SHA512 bc5b50dfa3390df878c0f97064a863b36bfa74a0eeb3130933d628f0837c2ca663b93a42a7a114311976ea44cbbc67439390385bf3e451f64b755c74db88ddb4 WHIRLPOOL 9d40ed82df3a1cd6d550561247f34b4c78c8620a10e0c16129c0c8735aaca2d6cdd90352672146ebe5e4f4096a37d19142d5c66ee60dd0184d57d5d0b1bc8dec
diff --git a/media-sound/lastfm-desktop/files/lastfm-desktop-2.1.36-missing-cast.patch b/media-sound/lastfm-desktop/files/lastfm-desktop-2.1.36-missing-cast.patch
new file mode 100644
index 000000000000..12d19d36d3e9
--- /dev/null
+++ b/media-sound/lastfm-desktop/files/lastfm-desktop-2.1.36-missing-cast.patch
@@ -0,0 +1,25 @@
+From 192b979c57aa0b9a2df4f11ad4851ce4fbf5d38b Mon Sep 17 00:00:00 2001
+From: Spiek <spiek@ymail.com>
+Date: Fri, 27 Dec 2013 13:27:11 +0100
+Subject: [PATCH] Fix missing Cast
+
+---
+ app/client/Services/RadioService/RadioService.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/app/client/Services/RadioService/RadioService.cpp b/app/client/Services/RadioService/RadioService.cpp
+index 05f22c8..10094b6 100644
+--- a/app/client/Services/RadioService/RadioService.cpp
++++ b/app/client/Services/RadioService/RadioService.cpp
+@@ -307,7 +307,7 @@
+ void
+ RadioService::onPhononStateChanged( Phonon::State newstate, Phonon::State oldstate )
+ {
+- qDebug() << oldstate << " -> " << newstate;
++ qDebug() << (int)oldstate << " -> " << (int)newstate;
+ if (m_mediaObject == 0) {
+ qDebug() << "m_mediaObject is null!";
+ return;
+--
+1.8.5.5
+
diff --git a/media-sound/lastfm-desktop/lastfm-desktop-2.1.35.ebuild b/media-sound/lastfm-desktop/lastfm-desktop-2.1.35.ebuild
new file mode 100644
index 000000000000..7c44efdc1a1e
--- /dev/null
+++ b/media-sound/lastfm-desktop/lastfm-desktop-2.1.35.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2
+
+DESCRIPTION="The official Last.fm desktop application suite"
+HOMEPAGE="http://www.last.fm https://github.com/lastfm/lastfm-desktop"
+SRC_URI="https://github.com/lastfm/lastfm-desktop/archive/2.1.35.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtsql:4
+ dev-qt/qtwebkit:4
+ media-libs/libgpod
+ >=media-libs/liblastfm-1.0.6[fingerprint]
+ sys-libs/zlib
+ || ( dev-qt/qtphonon:4 kde-apps/phonon-kde:4 )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake4 Last.fm.pro PREFIX="${EPREFIX}"/usr
+}
diff --git a/media-sound/lastfm-desktop/lastfm-desktop-2.1.36.ebuild b/media-sound/lastfm-desktop/lastfm-desktop-2.1.36.ebuild
new file mode 100644
index 000000000000..08b682479d91
--- /dev/null
+++ b/media-sound/lastfm-desktop/lastfm-desktop-2.1.36.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2
+
+DESCRIPTION="The official Last.fm desktop application suite"
+HOMEPAGE="http://www.last.fm https://github.com/lastfm/lastfm-desktop"
+SRC_URI="https://github.com/lastfm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtsql:4
+ dev-qt/qtwebkit:4
+ media-libs/libgpod
+ media-libs/liblastfm[fingerprint]
+ sys-libs/zlib
+ || ( dev-qt/qtphonon:4 kde-apps/phonon-kde:4 )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-missing-cast.patch )
+
+src_configure() {
+ eqmake4 Last.fm.pro PREFIX="${EPREFIX}"/usr
+}
diff --git a/media-sound/lastfm-desktop/metadata.xml b/media-sound/lastfm-desktop/metadata.xml
new file mode 100644
index 000000000000..883aeb431414
--- /dev/null
+++ b/media-sound/lastfm-desktop/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lastfm/lastfm-desktop</remote-id>
+ </upstream>
+</pkgmetadata>