summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Brasseur <nielzsen@protonmail.com>2023-02-13 11:00:32 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-02-25 13:03:52 +0200
commitd5312dc3bb177aeaee69cabcea9c4c988c8de71e (patch)
treef6864dc3533e02b2ba891868866695c224c6bd9b /media-sound/lollypop
parentdev-libs/efl: add missing xorg-proto dep (diff)
downloadgentoo-d5312dc3bb177aeaee69cabcea9c4c988c8de71e.tar.gz
gentoo-d5312dc3bb177aeaee69cabcea9c4c988c8de71e.tar.bz2
gentoo-d5312dc3bb177aeaee69cabcea9c4c988c8de71e.zip
media-sound/lollypop: add 1.4.37
Signed-off-by: Roman Brasseur <nielzsen@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/29568 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-sound/lollypop')
-rw-r--r--media-sound/lollypop/Manifest1
-rw-r--r--media-sound/lollypop/lollypop-1.4.37.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index adb20131fb22..38d850355d4d 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1,2 +1,3 @@
DIST lollypop-1.4.29.tar.xz 593980 BLAKE2B 8a3a985cb18c196665377c7c29670b98f352a86284ee8bb5af13b1017346b0b2b938dee6e53d56d0b8d98b191a64e5efd1c7126879c7017c3f10d5aa96570a39 SHA512 f81315a94cbcc726cd453d58faffe5c33ebcbdaef55a5a36d2a9dc20dec9340c2d263d935b5115148b049fca52e57c88eac36386e56f0965f22674eba26ae813
DIST lollypop-1.4.35.tar.xz 596016 BLAKE2B 6776d98d8d0da18dade3ac022ea7980e9762834ebaadae453abb0dd0f0d98298f2457d2cb18f21159e2d12d4735d3c87740b0449a090f7778b7d77ba82634e40 SHA512 8cde0db23dd011370fbcf2a32389f801d7586598bb653b921f4525af17e2eb4771a306e34a340bb8c4a1666727c4b1c3a84490f362ca3c473fb7c5b3982a644d
+DIST lollypop-1.4.37.tar.xz 600812 BLAKE2B 08719d3c370332d398cb7dfc3c89128c895f89b0f5ca2b10fd85b1ef88d79ec96fbf945bbf4549e029e80726c80ccf6212e87d13b8808c08615626c6f01a4297 SHA512 9266677e8200626859793693e8cbf0e76b134fe37ff1b915841c1aebb5785eaaf1af5325c57bed78e887c98e947101103b1898d81c62cd9517b3420aebfeb685
diff --git a/media-sound/lollypop/lollypop-1.4.37.ebuild b/media-sound/lollypop/lollypop-1.4.37.ebuild
new file mode 100644
index 000000000000..b5af4d31d54f
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.4.37.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+inherit python-single-r1 gnome2-utils meson xdg
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# Dependencies being checked by Meson
+COMMON_DEPEND="
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ net-libs/libsoup:2.4[introspection]
+ x11-libs/gtk+:3[introspection]
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+"
+
+BDEPEND="
+ ${COMMON_DEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? (
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ )
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ media-plugins/gst-plugins-pulse
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser[introspection]
+ gui-libs/libhandy:1[introspection]
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}/usr/bin"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ elog "Remember to install the necessary gst-plugins packages to read your audio files."
+ elog "You can also use the gst-plugins-meta pakcage and its USE flags."
+ elog "Lollypop now relies on yt-dlp instead of youtube-dl, since version 1.4.36."
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}