summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-15 20:59:48 +0000
committerSam James <sam@gentoo.org>2022-05-15 21:00:40 +0000
commitefcf421ff9e351b8003a1ca60d107b766f099461 (patch)
tree431e629fd4dec7636b1f9c9a657063d6678f2a67 /media-sound/pulseeffects
parentx11-wm/mutter: Call udev_reload (diff)
downloadgentoo-efcf421ff9e351b8003a1ca60d107b766f099461.tar.gz
gentoo-efcf421ff9e351b8003a1ca60d107b766f099461.tar.bz2
gentoo-efcf421ff9e351b8003a1ca60d107b766f099461.zip
media-sound/pulseeffects: fix build with Boost 1.79
Closes: https://bugs.gentoo.org/844898 Thanks-to: Sven Hesse <drmccoy@drmccoy.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/pulseeffects')
-rw-r--r--media-sound/pulseeffects/files/pulseeffects-4.8.6-boost_1.79.patch25
-rw-r--r--media-sound/pulseeffects/pulseeffects-4.8.6.ebuild1
2 files changed, 26 insertions, 0 deletions
diff --git a/media-sound/pulseeffects/files/pulseeffects-4.8.6-boost_1.79.patch b/media-sound/pulseeffects/files/pulseeffects-4.8.6-boost_1.79.patch
new file mode 100644
index 000000000000..825aaca32822
--- /dev/null
+++ b/media-sound/pulseeffects/files/pulseeffects-4.8.6-boost_1.79.patch
@@ -0,0 +1,25 @@
+https://bugs.gentoo.org/844898
+https://github.com/wwmm/easyeffects/commit/1000de1c27f422fb2fd6106c554844e9d81925cf
+
+From: Sven Hesse <drmccoy@drmccoy.de>
+Date: Sun, 15 May 2022 19:04:32 +0200
+Subject: [PATCH] fix compilation with Boost 1.79.0
+
+Boost.Filesystem in Boost 1.79.0 changed the already-deprecated header
+of string_file.hpp to be not included by default anymore in its commit
+266e1ac892a6f54d807fb35bf639a9aa1c8b2db1.
+
+Boost.Filesystem's fstream.hpp was never included directly by default,
+but string_file.hpp did include it, so this code here in PulseEffects
+worked. With Boost 1.79.0, though, it explodes in lin 179.
+--- a/src/general_settings_ui.cpp
++++ b/src/general_settings_ui.cpp
+@@ -21,6 +21,7 @@
+ #include <giomm/file.h>
+ #include <glibmm.h>
+ #include <boost/filesystem.hpp>
++#include <boost/filesystem/fstream.hpp>
+ #include "util.hpp"
+
+ namespace {
+
diff --git a/media-sound/pulseeffects/pulseeffects-4.8.6.ebuild b/media-sound/pulseeffects/pulseeffects-4.8.6.ebuild
index bf1d9aac8112..cb43e0354667 100644
--- a/media-sound/pulseeffects/pulseeffects-4.8.6.ebuild
+++ b/media-sound/pulseeffects/pulseeffects-4.8.6.ebuild
@@ -61,6 +61,7 @@ BDEPEND="dev-libs/appstream-glib
PATCHES=(
"${FILESDIR}"/${PN}-4.8.6-meson_no_automagic.patch
+ "${FILESDIR}"/${P}-boost_1.79.patch
)
S="${WORKDIR}"/easyeffects-${PV}