summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-02-07 15:41:56 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-02-07 15:42:10 +0100
commit643fa50bb6f0bbb52c5e176d3d905027fdedb7f4 (patch)
treed43f2444ba072d8104f55c338920bd0efdd96e25 /media-sound/qsampler
parentlxde-base/lxdm: Drop old; cleanup metadata (diff)
downloadgentoo-643fa50bb6f0bbb52c5e176d3d905027fdedb7f4.tar.gz
gentoo-643fa50bb6f0bbb52c5e176d3d905027fdedb7f4.tar.bz2
gentoo-643fa50bb6f0bbb52c5e176d3d905027fdedb7f4.zip
media-sound/qsampler: bump to 0.9.1, switched to cmake, updated live
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/qsampler')
-rw-r--r--media-sound/qsampler/Manifest1
-rw-r--r--media-sound/qsampler/files/qsampler-0.9.1-cmake-no-git.patch21
-rw-r--r--media-sound/qsampler/qsampler-0.9.1.ebuild58
-rw-r--r--media-sound/qsampler/qsampler-9999.ebuild38
4 files changed, 99 insertions, 19 deletions
diff --git a/media-sound/qsampler/Manifest b/media-sound/qsampler/Manifest
index 66b24d017d63..894056cf7277 100644
--- a/media-sound/qsampler/Manifest
+++ b/media-sound/qsampler/Manifest
@@ -1 +1,2 @@
DIST qsampler-0.6.3.tar.gz 284613 BLAKE2B a4ef67014578b4eb7b6f6e7b5da94b04253a40bed0cc413acfde62f4660d2e1d3485d301637d1871e7f20dcdac34ea81511738a4455f8690f40460d7ea4db72b SHA512 55fe16d5cfe0245cfedb228d448235997160471343191cf204347bb13c260be747a06fce2344b36a60c5877f89b32b0f4ac4861ed8a3d555d4cc798f21f5e1ae
+DIST qsampler-0.9.1.tar.gz 283857 BLAKE2B 5d30c64edd4c1792d9e87453af45363ebdac6707ef6f804dc867b4eb23fdd657bbf554cd706ddcaa0c6bbe35deeaa1c8d1ff0f1e5af3cad005ebed94f43fed7d SHA512 5afda874b01ed576522898e04f9d264fccd589da292659eb9947786d3642c80d41629fd5d2268caa53f3ae0a96f0a1c84600a3651e8758d39d5c0220a9bba57d
diff --git a/media-sound/qsampler/files/qsampler-0.9.1-cmake-no-git.patch b/media-sound/qsampler/files/qsampler-0.9.1-cmake-no-git.patch
new file mode 100644
index 000000000000..44b7c3cb6443
--- /dev/null
+++ b/media-sound/qsampler/files/qsampler-0.9.1-cmake-no-git.patch
@@ -0,0 +1,21 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8304e80..666deb5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,6 +6,7 @@ project(qsampler
+ LANGUAGES C CXX)
+
+ set (CONFIG_VERSION ${PROJECT_VERSION})
++#[[
+ execute_process (
+ COMMAND git describe --tags --dirty --abbrev=6
+ OUTPUT_VARIABLE GIT_DESCRIBE_OUTPUT
+@@ -27,6 +28,8 @@ if (GIT_DESCRIBE_RESULT EQUAL 0)
+ else ()
+ set (VERSION "${PROJECT_VERSION}")
+ endif ()
++]]
++set (VERSION "${PROJECT_VERSION}")
+
+ set (PACKAGE_NAME "Qsampler")
+ set (PACKAGE_VERSION "${VERSION}")
diff --git a/media-sound/qsampler/qsampler-0.9.1.ebuild b/media-sound/qsampler/qsampler-0.9.1.ebuild
new file mode 100644
index 000000000000..d2d0dd804cbe
--- /dev/null
+++ b/media-sound/qsampler/qsampler-0.9.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake qmake-utils xdg
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/qsampler/code"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Graphical frontend to the LinuxSampler engine"
+HOMEPAGE="https://qsampler.sourceforge.io/ https://www.linuxsampler.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +libgig"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/alsa-lib
+ media-libs/liblscp:=
+ x11-libs/libX11
+ libgig? ( media-libs/libgig:= )
+"
+RDEPEND="${DEPEND}
+ media-sound/linuxsampler
+"
+BDEPEND="dev-qt/linguist-tools:5"
+
+PATCHES=(
+ "${FILESDIR}/${P}-cmake-no-git.patch"
+)
+
+DOCS=( AUTHORS ChangeLog README TODO TRANSLATORS )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "/^find_package.*QT/s/Qt6 //" -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ -DCONFIG_LIBGIG=$(usex libgig 1 0)
+ )
+ cmake_src_configure
+}
diff --git a/media-sound/qsampler/qsampler-9999.ebuild b/media-sound/qsampler/qsampler-9999.ebuild
index 23f189c07e1c..cd513200a60b 100644
--- a/media-sound/qsampler/qsampler-9999.ebuild
+++ b/media-sound/qsampler/qsampler-9999.ebuild
@@ -1,10 +1,17 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-EGIT_REPO_URI="https://git.code.sf.net/p/qsampler/code"
-inherit qmake-utils xdg autotools git-r3
+inherit cmake qmake-utils xdg
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/qsampler/code"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="Graphical frontend to the LinuxSampler engine"
HOMEPAGE="https://qsampler.sourceforge.io/ https://www.linuxsampler.org/"
@@ -21,34 +28,27 @@ DEPEND="
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
media-libs/alsa-lib
- >=media-libs/liblscp-0.5.6:=
+ media-libs/liblscp:=
x11-libs/libX11
- libgig? ( >=media-libs/libgig-3.3.0:= )
+ libgig? ( media-libs/libgig:= )
"
RDEPEND="${DEPEND}
- >=media-sound/linuxsampler-0.5
+ media-sound/linuxsampler
"
BDEPEND="dev-qt/linguist-tools:5"
DOCS=( AUTHORS ChangeLog README TODO TRANSLATORS )
-PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )
-
src_prepare() {
- default
+ cmake_src_prepare
- emake -f Makefile.git
- eautoreconf
+ sed -e "/^find_package.*QT/s/Qt6 //" -i CMakeLists.txt || die
}
src_configure() {
- local myeconfargs=(
- $(use_enable debug)
- $(use_enable libgig)
+ local mycmakeargs=(
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ -DCONFIG_LIBGIG=$(usex libgig 1 0)
)
- ac_qmake="$(qt5_get_bindir)/qmake" \
- econf "${myeconfargs[@]}"
-
- cd src || die
- eqmake5 src.pro -o Makefile
+ cmake_src_configure
}