summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-09-12 07:58:52 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-09-12 07:59:05 +0200
commit51eecd4632901b71ae51644ddeb52d2ca42dd9b9 (patch)
tree102162e27a1e47e925c7a4f6220605b2f2203287 /media-sound/qsynth
parentdev-util/bpftool: Stabilize 7.5.0-r1 amd64, #939462 (diff)
downloadgentoo-51eecd4632901b71ae51644ddeb52d2ca42dd9b9.tar.gz
gentoo-51eecd4632901b71ae51644ddeb52d2ca42dd9b9.tar.bz2
gentoo-51eecd4632901b71ae51644ddeb52d2ca42dd9b9.zip
media-sound/qsynth: bump to 1.0.1
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/qsynth')
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-1.0.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index 75f31e8bca43..815e8ba41691 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1 +1,2 @@
DIST qsynth-1.0.0.tar.gz 337358 BLAKE2B 40e2b6aacf21eb17169b0899f1b089cb2869295fd5a3b87a4d0e8d7632bce8518ce4d2dc22dafa2c9d4fafe0211c90b9729432a7407bd35f8237c357ce1cb897 SHA512 9533cb425345a83ed9695917885cba52278035c2a6f7b824981b9ec5033b5d61b7ac050cc7e516a6aa7f4ff76e29eb29089a93a727294e7a6a1e5fb631720ea4
+DIST qsynth-1.0.1.tar.gz 338049 BLAKE2B 9fc3d70aa20af4523a0c1e8ff6d9190b30359b7cd5fa1516e8ad0e6cc9aa0ec9e23cfc850e2796519fa462c0028550c9c43eebb8f1dc413bc9e5fd5a953ba6e8 SHA512 be81442e3eb50cdd8075e7674413c8f9b297bc19c799da138bc8491dc225f03290856d4048b27dcc192fab636d4175ed457bdf798f3a4b61c2b195c2e8a92b33
diff --git a/media-sound/qsynth/qsynth-1.0.1.ebuild b/media-sound/qsynth/qsynth-1.0.1.ebuild
new file mode 100644
index 000000000000..496e8129a1ca
--- /dev/null
+++ b/media-sound/qsynth/qsynth-1.0.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop xdg
+
+DESCRIPTION="Qt application to control FluidSynth"
+HOMEPAGE="https://qsynth.sourceforge.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
+ inherit git-r3
+else
+ SRC_URI="https://downloads.sourceforge.net/qsynth/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa debug jack pulseaudio qt6"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+BDEPEND="
+ qt6? ( dev-qt/qttools:6[linguist] )
+ !qt6? ( dev-qt/linguist-tools:5 )
+"
+DEPEND="
+ qt6? (
+ dev-qt/qtbase:6[gui,network,widgets]
+ dev-qt/qtsvg:6
+ )
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )
+ media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ -DCONFIG_QT6=$(usex qt6 1 0)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${D}/usr/share/applications/org.rncbc.qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth org.rncbc.qsynth
+}