summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-26 07:21:44 +0100
committerSam James <sam@gentoo.org>2022-07-26 07:22:06 +0100
commit876ecd41959cad8a382e2b364bf214c70ace77d5 (patch)
tree11ccc69ac7750079661a5c469edf774c5f7de76b /media-sound/spek/spek-0.8.4.ebuild
parentprofiles: last-rite media-libs/libgroove (diff)
downloadgentoo-876ecd41959cad8a382e2b364bf214c70ace77d5.tar.gz
gentoo-876ecd41959cad8a382e2b364bf214c70ace77d5.tar.bz2
gentoo-876ecd41959cad8a382e2b364bf214c70ace77d5.zip
media-sound/spek: add 0.8.4
Makes ffmpeg 5 situation better but not yet enough. Bug: https://bugs.gentoo.org/834397 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/spek/spek-0.8.4.ebuild')
-rw-r--r--media-sound/spek/spek-0.8.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/spek/spek-0.8.4.ebuild b/media-sound/spek/spek-0.8.4.ebuild
new file mode 100644
index 000000000000..dbfa6ab4d593
--- /dev/null
+++ b/media-sound/spek/spek-0.8.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit wxwidgets xdg
+
+DESCRIPTION="Analyse your audio files by showing their spectrogram"
+HOMEPAGE="http://www.spek-project.org/"
+SRC_URI="https://github.com/alexkay/spek/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-video/ffmpeg:=
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.4-disable-updates.patch
+)
+
+src_configure() {
+ setup-wxwidgets unicode
+ default
+}