summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgentoo-setan <gentoo-setan@protonmail.com>2024-06-17 08:41:12 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-07-18 10:48:15 +0300
commit791f5efa19517aa9f50d205eda399e94998e3b72 (patch)
tree8d7bb08e6f255b09d598d3d11b64e92d442e5734 /media-sound
parentmedia-sound/ncmpcpp: update HOMEPAGE, add dep version, fix pkgcheck (diff)
downloadgentoo-791f5efa19517aa9f50d205eda399e94998e3b72.tar.gz
gentoo-791f5efa19517aa9f50d205eda399e94998e3b72.tar.bz2
gentoo-791f5efa19517aa9f50d205eda399e94998e3b72.zip
media-sound/ncmpcpp: make 9999 more like latest stable
Signed-off-by: gentoo-setan <gentoo-setan@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/37190 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ncmpcpp/ncmpcpp-9999.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/media-sound/ncmpcpp/ncmpcpp-9999.ebuild b/media-sound/ncmpcpp/ncmpcpp-9999.ebuild
index 83a7d42906c9..8c02f3f600fe 100644
--- a/media-sound/ncmpcpp/ncmpcpp-9999.ebuild
+++ b/media-sound/ncmpcpp/ncmpcpp-9999.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools git-r3
-DESCRIPTION="featureful ncurses based MPD client inspired by ncmpc"
+DESCRIPTION="Featureful ncurses based MPD client inspired by ncmpc"
HOMEPAGE="
https://rybczak.net/ncmpcpp/
https://github.com/ncmpcpp/ncmpcpp/
"
EGIT_REPO_URI="https://github.com/ncmpcpp/ncmpcpp"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
IUSE="clock outputs taglib visualizer"
@@ -26,18 +26,15 @@ RDEPEND="
taglib? ( media-libs/taglib )
visualizer? ( sci-libs/fftw:3.0= )
"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
-
- sed -i -e '/^docdir/d' {,doc/}Makefile.am || die
- sed -i -e 's|COPYING||g' Makefile.am || die
-
eautoreconf
+
+ sed -i -e '/^docdir/d' {,doc/}Makefile{.am,.in} || die
+ sed -i -e 's|COPYING||g' Makefile{.am,.in} || die
}
src_configure() {
@@ -60,7 +57,7 @@ src_install() {
pkg_postinst() {
echo
elog "Example configuration files have been installed at"
- elog "${ROOT}/usr/share/doc/${PF}"
+ elog "${EROOT}/usr/share/doc/${PF}"
elog "${P} uses ~/.ncmpcpp/config and ~/.ncmpcpp/bindings"
elog "as user configuration files."
echo