summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-03 00:52:04 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-02-03 09:30:13 +0100
commit7da5c1b7adc92028731881d7882a506cd091e760 (patch)
tree2dcf0917981eebd01d47cd0f50f29716561eb9cf /media-sound
parentdev-libs/libsigsegv: Remove old (diff)
downloadgentoo-7da5c1b7adc92028731881d7882a506cd091e760.tar.gz
gentoo-7da5c1b7adc92028731881d7882a506cd091e760.tar.bz2
gentoo-7da5c1b7adc92028731881d7882a506cd091e760.zip
media-sound/qjackctl: Switch to cmake, add missing DEPEND and RDEPEND
Bug: https://bugs.gentoo.org/766300 Closes: https://github.com/gentoo/gentoo/pull/19312 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qjackctl/qjackctl-9999.ebuild47
1 files changed, 16 insertions, 31 deletions
diff --git a/media-sound/qjackctl/qjackctl-9999.ebuild b/media-sound/qjackctl/qjackctl-9999.ebuild
index 55ceab1b20dc..0a4e44949eb1 100644
--- a/media-sound/qjackctl/qjackctl-9999.ebuild
+++ b/media-sound/qjackctl/qjackctl-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic qmake-utils autotools git-r3 xdg
+inherit xdg cmake git-r3
DESCRIPTION="Qt GUI to control the JACK Audio Connection Kit and ALSA sequencer connections"
HOMEPAGE="https://qjackctl.sourceforge.io/"
@@ -15,44 +15,29 @@ KEYWORDS=""
IUSE="alsa dbus debug portaudio"
BDEPEND="dev-qt/linguist-tools:5"
-RDEPEND="
- app-arch/gzip
+DEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
dev-qt/qtxml:5
virtual/jack
alsa? ( media-libs/alsa-lib )
dbus? ( dev-qt/qtdbus:5 )
- portaudio? ( media-libs/portaudio )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
- eautoreconf
-}
+ portaudio? ( media-libs/portaudio )
+"
+RDEPEND="${DEPEND}
+ dev-qt/qtsvg:5
+"
src_configure() {
- append-cxxflags -std=c++11
- local myeconfargs=(
- $(use_enable alsa alsa-seq)
- $(use_enable dbus)
- $(use_enable debug)
- $(use_enable portaudio)
- --enable-jack-version
+ local mycmakeargs=(
+ -DCONFIG_ALSA_SEQ=$(usex alsa 1 0)
+ -DCONFIG_DBUS=$(usex dbus 1 0)
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ -DCONFIG_PORTAUDIO=$(usex portaudio 1 0)
+ -DCONFIG_JACK_VERSION=1
)
- econf "${myeconfargs[@]}"
- eqmake5 ${PN}.pro -o ${PN}.mak
-}
-
-src_compile() {
- emake -f ${PN}.mak
-}
-
-src_install() {
- default
-
- gunzip "${D}/usr/share/man/man1/qjackctl.1.gz" || die
- gunzip "${D}/usr/share/man/fr/man1/qjackctl.1.gz" || die
+ cmake_src_configure
}