summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-30 12:21:52 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-30 14:39:39 +0200
commitd6b8463f1e86a67781e4bd20b2911ad2d98340ad (patch)
tree54a0de83ff236d82a316e518699b2009e4b2cbd5 /media-tv
parentmedia-libs/nanosvg: add 20231202 (diff)
downloadgentoo-d6b8463f1e86a67781e4bd20b2911ad2d98340ad.tar.gz
gentoo-d6b8463f1e86a67781e4bd20b2911ad2d98340ad.tar.bz2
gentoo-d6b8463f1e86a67781e4bd20b2911ad2d98340ad.zip
media-tv/mythtv-status: add 1.1.0
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37374 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv-status/Manifest1
-rw-r--r--media-tv/mythtv-status/mythtv-status-1.1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/media-tv/mythtv-status/Manifest b/media-tv/mythtv-status/Manifest
index 6849e4b27dd1..9b8a91da9dde 100644
--- a/media-tv/mythtv-status/Manifest
+++ b/media-tv/mythtv-status/Manifest
@@ -1 +1,2 @@
DIST mythtv-status-1.0.1.tar.gz 45990 BLAKE2B 439d1b4a0d324a94e947139cd7038ba623532f414a43a8a6f481f5630cba9d6801288bd684e92c59c465f8f65683fc7b86efb47700b6ff58e1b299ca81442d19 SHA512 9f0a3a38c91ec451f2c95177d8acc7566705ec77e601fe40cdf97d8f8ccf5f9b55e419d42309e1601e128c0344103ffe75d10a06bcb15d5a1617ad30424dbc1a
+DIST mythtv-status-1.1.0.tar.gz 47393 BLAKE2B b444ac83c2c6d6d3dbcd28485de974201510e14d4d773be5fbe867ddcc25fec20369d40f52b3d87a72cfb2b04ffd8c61861dcf4e013d70974053bf732165fc4f SHA512 4a0fd49cb36624d0da677f901ae48ae7c2971e3d18e0a2669cbfe137ed540321373fe9118aa603ef6fcf0397c4af0ee5a5086d20481cdcedc47b5881ff8da3f5
diff --git a/media-tv/mythtv-status/mythtv-status-1.1.0.ebuild b/media-tv/mythtv-status/mythtv-status-1.1.0.ebuild
new file mode 100644
index 000000000000..8bae575f0074
--- /dev/null
+++ b/media-tv/mythtv-status/mythtv-status-1.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Displays the current status of MythTV at the command prompt"
+HOMEPAGE="http://www.etc.gen.nz/projects/mythtv/mythtv-status.html"
+SRC_URI="http://www.etc.gen.nz/projects/mythtv/tarballs/${P}.tar.gz"
+#SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-perl/libwww-perl
+ dev-perl/XML-LibXML
+ dev-perl/Date-Manip
+ dev-perl/MIME-tools
+ dev-perl/Sys-SigAction
+ dev-perl/Config-Auto
+ media-tv/mythtv[perl]"
+
+src_compile() { :; }
+
+src_install() {
+ dobin bin/${PN}
+ newman "${FILESDIR}"/${PN}-1.0.1.man ${PN}.1
+ dodoc README FAQ ChangeLog THANKS
+}
+
+src_test() {
+ emake test
+}