summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/ffmpegthumbnailer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/ffmpegthumbnailer')
-rw-r--r--media-video/ffmpegthumbnailer/Manifest2
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.10.ebuild53
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.8.ebuild45
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch23
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch47
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch46
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.8-memcpy.patch13
-rw-r--r--media-video/ffmpegthumbnailer/metadata.xml11
8 files changed, 240 insertions, 0 deletions
diff --git a/media-video/ffmpegthumbnailer/Manifest b/media-video/ffmpegthumbnailer/Manifest
new file mode 100644
index 000000000000..a036401d12af
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/Manifest
@@ -0,0 +1,2 @@
+DIST ffmpegthumbnailer-2.0.10.tar.bz2 2154028 SHA256 a3022c86aa3e704849e424147bd4a319867e18930d66a4a4c93c0baefdd1fc60 SHA512 1fcfcfe9457a3e3e70a749f3234f79d080fbbb40d4d1f65b84e1c46a7051c75368afaffb25a39b43f8e205ffdbc2e156e6fb5848514fce4a1a3f5222458c1b9d WHIRLPOOL fe60513d2a26db622d02f6f38f04009590337415aeb02b441757949e4402cdfeb33d37cb295720f8dd66ebae9dcfdba9304c88256ccda4800e015fa40650151b
+DIST ffmpegthumbnailer-2.0.8.tar.gz 367186 SHA256 2c8bbefa838d38ea42fc8ac78258cda36865d974c991624b14cffdb92a3bc68b SHA512 6062d4b8f5326bde96c8c6dceaac52e1fabcec93f0a0ee4be19e203050e6c80426a006076a27e4a12582e05daceebd37beef008154fdd92a87f365fdff68ca83 WHIRLPOOL 6b0bd942777515f690f212df5616dffc4fc1c6e0e0e5be67128b376347b18d75eb144d25e9f8ac841b41099703092af5784edc31f34d7dbf81b742d678233e79
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.10.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.10.ebuild
new file mode 100644
index 000000000000..96de427c9ba5
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.10.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
+HOMEPAGE="https://github.com/dirkvdb/ffmpegthumbnailer"
+SRC_URI="https://github.com/dirkvdb/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gnome gtk jpeg libav png test"
+
+RDEPEND="
+ gtk? ( dev-libs/glib:2= )
+ jpeg? ( virtual/jpeg:0= )
+ !libav? ( >=media-video/ffmpeg-2.7:0= )
+ libav? ( >=media-video/libav-11:0= )
+ png? ( media-libs/libpng:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+REQUIRED_USE="gnome? ( gtk )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-config-summary.patch"
+ "${FILESDIR}/${P}-installdirs.patch"
+ "${FILESDIR}/${P}-set-locale.patch"
+)
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+src_prepare() {
+ rm -rf out* || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GIO=$(usex gtk)
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_THUMBNAILER=$(usex gnome)
+ -DHAVE_JPEG=$(usex jpeg)
+ -DHAVE_PNG=$(usex png)
+ )
+ cmake-utils_src_configure
+}
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.8.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.8.ebuild
new file mode 100644
index 000000000000..1e473cdf2867
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils libtool
+
+DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
+HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="gnome gtk jpeg png"
+
+COMMON_DEPEND=">=virtual/ffmpeg-0.10.2
+ png? ( media-libs/libpng:0= )
+ jpeg? ( virtual/jpeg )"
+RDEPEND="${COMMON_DEPEND}
+ gtk? ( >=dev-libs/glib-2.30 )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+REQUIRED_USE="gnome? ( gtk )"
+
+DOCS="AUTHORS ChangeLog README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-memcpy.patch
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable png) \
+ $(use_enable jpeg) \
+ $(use_enable gtk gio) \
+ $(use_enable gnome thumbnailer)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch
new file mode 100644
index 000000000000..608494559217
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch
@@ -0,0 +1,23 @@
+From 9c2a5fe997a6d8b00bef49eabb7bc49840882ec6 Mon Sep 17 00:00:00 2001
+From: Dirk Vanden Boer <dirk.vdb@gmail.com>
+Date: Wed, 29 Apr 2015 20:19:58 +0200
+Subject: [PATCH] Fixed configuration summary
+
+---
+ .travis.yml | 1 +
+ CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 22803d9..6b6e515 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -239,7 +239,7 @@ ELSE ()
+ MESSAGE(STATUS "register thumbnailer : disabled")
+ ENDIF ()
+
+-IF (ENABLE_UNITTEST)
++IF (ENABLE_TESTS)
+ MESSAGE(STATUS "unittests : enabled")
+ ELSE ()
+ MESSAGE(STATUS "unittests : disabled")
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch
new file mode 100644
index 000000000000..33a96b85735d
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch
@@ -0,0 +1,47 @@
+From 621274d694dee1f8c92f5db99a5cff98e82c6bd4 Mon Sep 17 00:00:00 2001
+From: Dirk Vanden Boer <dirk.vdb@gmail.com>
+Date: Sat, 2 May 2015 09:33:34 +0200
+Subject: [PATCH] Use proper gnu installation dirs (Thanks to Vallimar)
+
+---
+ CMakeLists.txt | 15 ++++++++-------
+ ChangeLog | 1 +
+ 2 files changed, 9 insertions(+), 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6b6e515..badb7cf 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,6 +25,7 @@ ENDIF ()
+
+ PROJECT(${PACKAGE})
+ INCLUDE(CPack)
++INCLUDE(GNUInstallDirs)
+
+ SET(CMAKE_EXPORT_COMPILE_COMMANDS 1)
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+@@ -189,17 +190,17 @@ ELSE ()
+ ENDIF ()
+
+ INSTALL(TARGETS ffmpegthumbnailer ${STATIC_LIB} ${SHARED_LIB}
+- LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib
+- RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX}/bin
+- ARCHIVE DESTINATION ${CMAKE_INSTALL_PREFIX}/lib
+- PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_PREFIX}/include/libffmpegthumbnailer
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/libffmpegthumbnailer
+ )
+
+-INSTALL(FILES man/ffmpegthumbnailer.1 DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1)
+-INSTALL(FILES ${CMAKE_BINARY_DIR}/libffmpegthumbnailer.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
++INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/man/ffmpegthumbnailer.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
++INSTALL(FILES ${CMAKE_BINARY_DIR}/libffmpegthumbnailer.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+
+ IF (ENABLE_THUMBNAILER)
+- INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dist/ffmpegthumbnailer.thumbnailer DESTINATION ${CMAKE_INSTALL_PREFIX}/share/thumbnailers)
++ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dist/ffmpegthumbnailer.thumbnailer DESTINATION ${CMAKE_INSTALL_DATADIR}/thumbnailers)
+ ENDIF ()
+
+ CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/config.h.in ${CMAKE_BINARY_DIR}/config.h)
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch
new file mode 100644
index 000000000000..b1a198a93a1e
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch
@@ -0,0 +1,46 @@
+From 718f1b1147fe7e9138e2d503ed151e589d643772 Mon Sep 17 00:00:00 2001
+From: Dirk Vanden Boer <dirk.vdb@gmail.com>
+Date: Sat, 18 Jul 2015 10:24:28 +0200
+Subject: [PATCH] Set locale to the user specified locale
+
+---
+ main.cpp | 5 ++---
+ test/testrunner.cpp | 7 ++-----
+ 2 files changed, 4 insertions(+), 8 deletions(-)
+
+diff --git a/main.cpp b/main.cpp
+index 6cb6c55..7cb7089 100644
+--- a/main.cpp
++++ b/main.cpp
+@@ -54,10 +54,9 @@ int main(int argc, char** argv)
+ string outputFile;
+ string imageFormat;
+
+- if (!setlocale(LC_CTYPE, "en_US.UTF-8"))
++ if (!std::setlocale(LC_CTYPE, ""))
+ {
+- std::cerr << "Locale not specified. Check LANG, LC_CTYPE, LC_ALL" << std::endl;
+- return 1;
++ std::cerr << "Failed to set locale" << std::endl;
+ }
+
+ while ((option = getopt (argc, argv, "i:o:s:t:q:c:afwhvp")) != -1)
+diff --git a/test/testrunner.cpp b/test/testrunner.cpp
+index 7023d25..20a4903 100644
+--- a/test/testrunner.cpp
++++ b/test/testrunner.cpp
+@@ -4,12 +4,9 @@
+ #include <gtest/gtest.h>
+
+ int main(int argc, char **argv) {
+- std::cout << "Running ffmpegthumbnailer tests" << std::endl;
+-
+- if (!setlocale(LC_CTYPE, "en_US.UTF-8"))
++ if (!std::setlocale(LC_CTYPE, ""))
+ {
+- std::cerr << "Locale not specified. Check LANG, LC_CTYPE, LC_ALL" << std::endl;
+- return 1;
++ std::cerr << "Failed to set locale" << std::endl;
+ }
+
+ testing::InitGoogleTest(&argc, argv);
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.8-memcpy.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.8-memcpy.patch
new file mode 100644
index 000000000000..5b9c68613e74
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.8-memcpy.patch
@@ -0,0 +1,13 @@
+libffmpegthumbnailer/pngwriter.cpp: In function 'void ffmpegthumbnailer::writeDataCallback(png_structp, png_bytep, png_size_t)':
+libffmpegthumbnailer/pngwriter.cpp:111:52: error: 'memcpy' was not declared in this scope
+
+--- libffmpegthumbnailer/pngwriter.cpp
++++ libffmpegthumbnailer/pngwriter.cpp
+@@ -17,6 +17,7 @@
+ #include "pngwriter.h"
+ #include <stdexcept>
+ #include <cassert>
++#include <cstring>
+
+ using namespace std;
+
diff --git a/media-video/ffmpegthumbnailer/metadata.xml b/media-video/ffmpegthumbnailer/metadata.xml
new file mode 100644
index 000000000000..26303e949898
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">ffmpegthumbnailer</remote-id>
+ </upstream>
+</pkgmetadata>