summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/gxine/gxine-0.5.907-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/gxine/gxine-0.5.907-r1.ebuild')
-rw-r--r--media-video/gxine/gxine-0.5.907-r1.ebuild102
1 files changed, 102 insertions, 0 deletions
diff --git a/media-video/gxine/gxine-0.5.907-r1.ebuild b/media-video/gxine/gxine-0.5.907-r1.ebuild
new file mode 100644
index 000000000000..ee4629106c24
--- /dev/null
+++ b/media-video/gxine/gxine-0.5.907-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils fdo-mime gnome2-utils multilib nsplugins
+
+DESCRIPTION="GTK+ Front-End for libxine"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xine/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="linguas_cs linguas_de lirc nls nsplugin udev +xcb xinerama"
+
+COMMON_DEPEND=">=media-libs/xine-lib-1.1.20
+ x11-libs/gtk+:2
+ >=dev-libs/glib-2
+ >=dev-lang/spidermonkey-1.8.2.15:0
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ lirc? ( app-misc/lirc )
+ nls? ( virtual/libintl )
+ nsplugin? ( dev-libs/nspr
+ x11-libs/libXaw
+ x11-libs/libXt )
+ udev? ( virtual/libgudev:= )
+ xcb? ( x11-libs/libxcb )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ # ld: cannot find -ljs
+ sed -i -e '/JS_LIBS="`spidermonkey_locate_lib/s:js:mozjs:' m4/_js.m4 || die
+
+ if has_version '>=dev-lang/spidermonkey-1.8.7:0'; then
+ sed -i -e 's:mozjs185:mozjs187:' m4/_js.m4 || die #422983
+ fi
+
+ epatch \
+ "${FILESDIR}"/${PN}-0.5.905-desktop.patch \
+ "${FILESDIR}"/${PN}-0.5.905-fix-nspr-useage.patch \
+ "${FILESDIR}"/${PN}-0.5.906-endif.patch \
+ "${FILESDIR}"/${PN}-0.5.907-glib-2.31.patch \
+ "${FILESDIR}"/${PN}-0.5.907-underlinking.patch
+
+ # need to disable calling of xine-list when running without
+ # userpriv, otherwise we get sandbox violations (bug #233847)
+ if [[ ${EUID} == "0" ]]; then
+ sed -i -e 's:^XINE_LIST=.*$:XINE_LIST=:' configure.ac || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable lirc) \
+ --enable-watchdog \
+ $(use_with xcb) \
+ $(has_version '<dev-lang/spidermonkey-1.8.5' && echo --with-spidermonkey=/usr/include/js) \
+ $(use_with nsplugin browser-plugin) \
+ $(use_with udev gudev) \
+ --without-hal \
+ --without-dbus \
+ $(use_with xinerama)
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install
+
+ dodoc AUTHORS BUGS ChangeLog README{,_l10n} TODO
+
+ use linguas_cs && dodoc README.cs
+ use linguas_de && dodoc README.de
+
+ use nsplugin && inst_plugin /usr/$(get_libdir)/gxine/gxineplugin.so
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}