summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-02-01 21:56:05 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2017-02-01 21:56:37 +0100
commitd47876dc688a95057033331269f7f829c7d2eca0 (patch)
tree924628c7e7dc1ac2d6f4836e8182e376ed3b4178 /media-video/orion
parentmail-filter/rspamd: restrict ragel dependency to < 7.0 (see bug 605056) (diff)
downloadgentoo-d47876dc688a95057033331269f7f829c7d2eca0.tar.gz
gentoo-d47876dc688a95057033331269f7f829c7d2eca0.tar.bz2
gentoo-d47876dc688a95057033331269f7f829c7d2eca0.zip
media-video/orion: 1.4.0 version bump
Add missing media-plugins/gst-plugins-hls rdep for USE=-mpv Thanks Nathan Caldwell <saintdev@gmail.com> in bug #607448 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-video/orion')
-rw-r--r--media-video/orion/Manifest1
-rw-r--r--media-video/orion/orion-1.4.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/media-video/orion/Manifest b/media-video/orion/Manifest
index 91e7817ead0f..dab82b1ab3f4 100644
--- a/media-video/orion/Manifest
+++ b/media-video/orion/Manifest
@@ -1 +1,2 @@
DIST orion-1.3.5.tar.gz 3213988 SHA256 0094b3202a7cfe0bc5139fd30e0cd371fce76abad3eb019d355dce67b715c8c6 SHA512 afd5540b2a61181c3db051fd39dd42f8a96799d19aab814f5846c5270f13bb0cb8305cd69e09e69cf215aeafb66682cc6d70379e791d6bffc551a38a8c751d0d WHIRLPOOL 8267cf6e261f33161cdadc527bd1ae23f830f903a010a1d58c59cde685a31827e554e992dd26b8ed5c712dcd6548c8500264a3c72c70506962b02dc76bd93593
+DIST orion-1.4.0.tar.gz 3375433 SHA256 4adb8ff6a3c24aed14a31d9c17474ee88df52b3cde5d5d1b48b41b4f7a0ae4a0 SHA512 0dadd66f806d9f4bf464e855b38e35cb762ba9cbc1c51a135e5fd489f3a5ebf80117f502eaa8225d0a4a72f15bc8e4858b92866148dc73ecc0d18fd1e1717bed WHIRLPOOL 638ccf87f11eb7c96c949e12d1a97333e156fde5dfb8e1abd315b362e2ddb49748c33a261deb32c531c40f544c8bbb26de681c35b2a32c0cee49888662dabab8
diff --git a/media-video/orion/orion-1.4.0.ebuild b/media-video/orion/orion-1.4.0.ebuild
new file mode 100644
index 000000000000..2d577ae19d59
--- /dev/null
+++ b/media-video/orion/orion-1.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit qmake-utils
+
+DESCRIPTION="Cross-platform Twitch client"
+HOMEPAGE="https://alamminsalo.github.io/orion/"
+SRC_URI="https://github.com/alamminsalo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mpv"
+
+DEPEND="dev-qt/qtquickcontrols:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebengine:5
+ mpv? ( media-video/mpv[libmpv] )
+ !mpv? ( dev-qt/qtmultimedia:5 )"
+RDEPEND="${DEPEND}
+ !mpv? ( media-plugins/gst-plugins-hls )"
+
+src_configure() {
+ # TODO: also supports qtav, not yet in portage
+ local PLAYER
+ if use mpv; then
+ PLAYER=mpv
+ else
+ PLAYER=multimedia
+ fi
+ eqmake5 ${PN}.pro CONFIG+=${PLAYER}
+}
+
+src_install() {
+ dobin ${PN}
+ domenu distfiles/*.desktop
+
+ insinto /usr/share/icons/hicolor/scalable/apps
+ doins distfiles/${PN}.svg
+}