summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-02 18:59:01 +0000
committerSam James <sam@gentoo.org>2020-08-02 18:59:01 +0000
commit4e4ffe217db49d10e5548718fdf324d0cf1070c5 (patch)
treef870a0d486cdd244d1853112ea749e808c56c49c /media-video/subliminal/subliminal-9999.ebuild
parentdev-python/pysrt: add Python 3.9 (diff)
downloadgentoo-4e4ffe217db49d10e5548718fdf324d0cf1070c5.tar.gz
gentoo-4e4ffe217db49d10e5548718fdf324d0cf1070c5.tar.bz2
gentoo-4e4ffe217db49d10e5548718fdf324d0cf1070c5.zip
media-video/subliminal: add Python 3.8, 3.9
A revbump is required because of new versions being added of the dependencies to support 3.8+. Closes: https://bugs.gentoo.org/718410 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/subliminal/subliminal-9999.ebuild')
-rw-r--r--media-video/subliminal/subliminal-9999.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/media-video/subliminal/subliminal-9999.ebuild b/media-video/subliminal/subliminal-9999.ebuild
index 54ade49d6223..5baa2d5e19fc 100644
--- a/media-video/subliminal/subliminal-9999.ebuild
+++ b/media-video/subliminal/subliminal-9999.ebuild
@@ -3,14 +3,12 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{7,8,9} )
PYTHON_REQ_USE='xml(+)'
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
-SRC_URI=""
-
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Diaoul/${PN}.git"
@@ -25,9 +23,14 @@ SRC_URI+=" test? ( mirror://sourceforge/matroska/test_files/matroska_test_w1_1.z
LICENSE="MIT"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
+BDEPEND="
+ test? (
+ app-arch/unzip
+ dev-python/sympy[${PYTHON_USEDEP}]
+ >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
+ )
+"
RDEPEND="
>=dev-python/appdirs-1.3[${PYTHON_USEDEP}]
>=dev-python/babelfish-0.5.2[${PYTHON_USEDEP}]
@@ -45,13 +48,6 @@ RDEPEND="
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
>=dev-python/stevedore-1.0.0[${PYTHON_USEDEP}]
"
-BDEPEND="
- test? (
- app-arch/unzip
- dev-python/sympy[${PYTHON_USEDEP}]
- >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
- )
-"
PATCHES=(
"${FILESDIR}/${PN}-2.1.0-fix-pytest-warning.patch"