summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-06-05 19:19:24 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-06-05 20:16:54 +0200
commit385167e12770fc12d22dfb873619b54c5292af6a (patch)
treeaee26378edee7b939debbc2fb1f2fb8315110dd2 /media-video/subtitlecomposer
parentapp-text/poppler: add 24.06.0 (diff)
downloadgentoo-385167e12770fc12d22dfb873619b54c5292af6a.tar.gz
gentoo-385167e12770fc12d22dfb873619b54c5292af6a.tar.bz2
gentoo-385167e12770fc12d22dfb873619b54c5292af6a.zip
media-video/subtitlecomposer: Fix build w/ ICU-75
See also: https://invent.kde.org/multimedia/subtitlecomposer/-/issues/100 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video/subtitlecomposer')
-rw-r--r--media-video/subtitlecomposer/files/subtitlecomposer-0.8.0-icu-75.patch36
-rw-r--r--media-video/subtitlecomposer/subtitlecomposer-0.8.0.ebuild3
2 files changed, 38 insertions, 1 deletions
diff --git a/media-video/subtitlecomposer/files/subtitlecomposer-0.8.0-icu-75.patch b/media-video/subtitlecomposer/files/subtitlecomposer-0.8.0-icu-75.patch
new file mode 100644
index 000000000000..89cef9917dec
--- /dev/null
+++ b/media-video/subtitlecomposer/files/subtitlecomposer-0.8.0-icu-75.patch
@@ -0,0 +1,36 @@
+From fe3cfc6455981cb6c7beae95713d22c431f3439e Mon Sep 17 00:00:00 2001
+From: Mladen Milinkovic <maxrd2@smoothware.net>
+Date: Wed, 22 May 2024 21:35:41 +0200
+Subject: [PATCH] Increased required std to C++17 #100
+
+C++17 is supported since gcc7 and ICU 75 headers require it.
+---
+ CMakeLists.txt | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e60e910a..fade001b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -7,17 +7,16 @@ if(QT_MAJOR_VERSION EQUAL 6)
+ set(QT_MIN_VERSION "6.0.0")
+ set(KF_MAJOR_VERSION "6")
+ set(KF_MIN_VERSION "5.240.0")
+- set(CMAKE_CXX_STANDARD 17)
+ else()
+ set(QT_EXTRA_COMPONENTS)
+ set(QT_MAJOR_VERSION 5)
+ set(QT_MIN_VERSION "5.9.0")
+ set(KF_MAJOR_VERSION "5")
+ set(KF_MIN_VERSION "5.44.0")
+- set(CMAKE_CXX_STANDARD 11)
+ endif()
+
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
++set(CMAKE_CXX_STANDARD 17)
+
+ find_package(ECM REQUIRED NO_MODULE)
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+--
+GitLab
+
diff --git a/media-video/subtitlecomposer/subtitlecomposer-0.8.0.ebuild b/media-video/subtitlecomposer/subtitlecomposer-0.8.0.ebuild
index 68d991328aa7..662986e1833f 100644
--- a/media-video/subtitlecomposer/subtitlecomposer-0.8.0.ebuild
+++ b/media-video/subtitlecomposer/subtitlecomposer-0.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -51,6 +51,7 @@ BDEPEND="
PATCHES=(
"${WORKDIR}/${PATCHSET}/${PN}-0.7.1-tests-optional.patch" # TODO: upstream
+ "${FILESDIR}/${P}-icu-75.patch" # git master
)
src_configure() {