summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-03 02:28:43 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-03 02:43:57 -0400
commit709e2ffb08e3c920ab8f3e01b750fa3d6c1ad736 (patch)
treea24f6454cfb8b6a58ef83f85761783bd886c2e73 /media-video
parentx11-drivers/nvidia-drivers: add kernel patches note to 390 (diff)
downloadgentoo-709e2ffb08e3c920ab8f3e01b750fa3d6c1ad736.tar.gz
gentoo-709e2ffb08e3c920ab8f3e01b750fa3d6c1ad736.tar.bz2
gentoo-709e2ffb08e3c920ab8f3e01b750fa3d6c1ad736.zip
media-video/mpv: backport old sub select behavior in 0.36.0
Unsure if a 0.36.1 is coming, but if not it may be worth it before consider stabling this one. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mpv/files/mpv-0.36.0-sub-match-audio.patch35
-rw-r--r--media-video/mpv/mpv-0.36.0-r1.ebuild (renamed from media-video/mpv/mpv-0.36.0.ebuild)1
2 files changed, 36 insertions, 0 deletions
diff --git a/media-video/mpv/files/mpv-0.36.0-sub-match-audio.patch b/media-video/mpv/files/mpv-0.36.0-sub-match-audio.patch
new file mode 100644
index 000000000000..d893b7b78c12
--- /dev/null
+++ b/media-video/mpv/files/mpv-0.36.0-sub-match-audio.patch
@@ -0,0 +1,35 @@
+Backport to restore --subs-with-matching-audio back to "yes" by default
+like it was in <0.36 to spare users from confusion and/or needlessly
+adjusting their configs until next version.
+
+https://github.com/mpv-player/mpv/issues/11854
+https://github.com/mpv-player/mpv/pull/12015
+https://github.com/mpv-player/mpv/commit/a2dd78fbc0932a4f47edbe4c41fe268095075c88
+--- a/DOCS/man/options.rst
++++ b/DOCS/man/options.rst
+@@ -140,11 +140,11 @@ Track Selection
+
+ ``--subs-with-matching-audio=<yes|no>``
+ When autoselecting a subtitle track, select a full/non-forced one even if the selected
+- audio stream matches your preferred subtitle language (default: no).
++ audio stream matches your preferred subtitle language (default: yes).
+
+ ``--subs-fallback=<yes|default|no>``
+ When autoselecting a subtitle track, if no tracks match your preferred languages,
+- select a full track even if it doesn't match your preferred subtitle language (default: no).
++ select a full track even if it doesn't match your preferred subtitle language (default: default).
+ Setting this to `default` means that only streams flagged as `default` will be selected.
+
+ ``--subs-fallback-forced=<yes|no>``
+--- a/options/options.c
++++ b/options/options.c
+@@ -1040,7 +1040,8 @@ static const struct MPOpts mp_default_opts = {
+ [STREAM_SUB] = (char *[]){ "auto", NULL },
+ },
+ .stream_auto_sel = true,
+- .subs_with_matching_audio = false,
++ .subs_with_matching_audio = true,
++ .subs_fallback = 1,
+ .subs_fallback_forced = true,
+ .audio_display = 1,
+ .audio_output_format = 0, // AF_FORMAT_UNKNOWN
diff --git a/media-video/mpv/mpv-0.36.0.ebuild b/media-video/mpv/mpv-0.36.0-r1.ebuild
index 1c181bdcbf33..5761951972fc 100644
--- a/media-video/mpv/mpv-0.36.0.ebuild
+++ b/media-video/mpv/mpv-0.36.0-r1.ebuild
@@ -135,6 +135,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.36.0-tests-odr.patch
+ "${FILESDIR}"/${PN}-0.36.0-sub-match-audio.patch
)
pkg_setup() {