summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-11 15:51:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-11 18:43:53 +0200
commitda6e5a8bc6d2a4598852471e692fefb94b71180a (patch)
treee9992cba8b968e9627e06587d9f7195065360a92 /media-video
parentprofiles: hppa: Drop obsolete dev-qt/qtbearer package.use.mask (diff)
downloadgentoo-da6e5a8bc6d2a4598852471e692fefb94b71180a.tar.gz
gentoo-da6e5a8bc6d2a4598852471e692fefb94b71180a.tar.bz2
gentoo-da6e5a8bc6d2a4598852471e692fefb94b71180a.zip
media-video/vlc: Fix build with >=dev-libs/fribidi-1
Thanks-to: Greg Turner <gmturner007@ameritech.net> Closes: https://bugs.gentoo.org/662662 Package-Manager: Portage-2.3.45, Repoman-2.3.10
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vlc/files/vlc-3.0.3-fribidi-1.patch80
-rw-r--r--media-video/vlc/vlc-3.0.3-r1.ebuild1
2 files changed, 81 insertions, 0 deletions
diff --git a/media-video/vlc/files/vlc-3.0.3-fribidi-1.patch b/media-video/vlc/files/vlc-3.0.3-fribidi-1.patch
new file mode 100644
index 000000000000..4431025a21e2
--- /dev/null
+++ b/media-video/vlc/files/vlc-3.0.3-fribidi-1.patch
@@ -0,0 +1,80 @@
+From 26e2d3906658c30f2f88f4b1bc9630ec43bf5525 Mon Sep 17 00:00:00 2001
+From: Shaleen Jain <shaleen@jain.sh>
+Date: Sun, 25 Feb 2018 18:42:27 +0530
+Subject: [PATCH] fribidi: update for version 1.0
+
+Update functions deprecated in version 1.0 when building with release 1.0 and
+above.
+
+Signed-off-by: Thomas Guillem <thomas@gllm.fr>
+---
+ modules/text_renderer/freetype/text_layout.c | 24 ++++++++++++++++++++
+ 1 file changed, 24 insertions(+)
+
+diff --git a/modules/text_renderer/freetype/text_layout.c b/modules/text_renderer/freetype/text_layout.c
+index 13efd567b46..1a28786d097 100644
+--- a/modules/text_renderer/freetype/text_layout.c
++++ b/modules/text_renderer/freetype/text_layout.c
+@@ -153,6 +153,9 @@ typedef struct paragraph_t
+
+ #ifdef HAVE_FRIBIDI
+ FriBidiCharType *p_types;
++#if FRIBIDI_MAJOR_VERSION >= 1
++ FriBidiBracketType *p_btypes;
++#endif
+ FriBidiLevel *p_levels;
+ FriBidiStrIndex *pi_reordered_indices;
+ FriBidiParType paragraph_type;
+@@ -361,6 +364,9 @@ static paragraph_t *NewParagraph( filter_t *p_filter,
+ #ifdef HAVE_FRIBIDI
+ p_paragraph->p_levels = vlc_alloc( i_size, sizeof( *p_paragraph->p_levels ) );
+ p_paragraph->p_types = vlc_alloc( i_size, sizeof( *p_paragraph->p_types ) );
++#if FRIBIDI_MAJOR_VERSION >= 1
++ p_paragraph->p_btypes = vlc_alloc( i_size, sizeof( *p_paragraph->p_btypes ) );
++#endif
+ p_paragraph->pi_reordered_indices =
+ vlc_alloc( i_size, sizeof( *p_paragraph->pi_reordered_indices ) );
+
+@@ -398,6 +404,9 @@ static paragraph_t *NewParagraph( filter_t *p_filter,
+ #ifdef HAVE_FRIBIDI
+ if( p_paragraph->p_levels ) free( p_paragraph->p_levels );
+ if( p_paragraph->p_types ) free( p_paragraph->p_types );
++#if FRIBIDI_MAJOR_VERSION >= 1
++ if( p_paragraph->p_btypes ) free( p_paragraph->p_btypes );
++#endif
+ if( p_paragraph->pi_reordered_indices )
+ free( p_paragraph->pi_reordered_indices );
+ #endif
+@@ -424,6 +433,9 @@ static void FreeParagraph( paragraph_t *p_paragraph )
+ #ifdef HAVE_FRIBIDI
+ free( p_paragraph->pi_reordered_indices );
+ free( p_paragraph->p_types );
++#if FRIBIDI_MAJOR_VERSION >= 1
++ free( p_paragraph->p_btypes );
++#endif
+ free( p_paragraph->p_levels );
+ #endif
+
+@@ -436,10 +448,22 @@ static int AnalyzeParagraph( paragraph_t *p_paragraph )
+ fribidi_get_bidi_types( p_paragraph->p_code_points,
+ p_paragraph->i_size,
+ p_paragraph->p_types );
++#if FRIBIDI_MAJOR_VERSION >= 1
++ fribidi_get_bracket_types( p_paragraph->p_code_points,
++ p_paragraph->i_size,
++ p_paragraph->p_types,
++ p_paragraph->p_btypes );
++ fribidi_get_par_embedding_levels_ex( p_paragraph->p_types,
++ p_paragraph->p_btypes,
++ p_paragraph->i_size,
++ &p_paragraph->paragraph_type,
++ p_paragraph->p_levels );
++#else
+ fribidi_get_par_embedding_levels( p_paragraph->p_types,
+ p_paragraph->i_size,
+ &p_paragraph->paragraph_type,
+ p_paragraph->p_levels );
++#endif
+
+ #ifdef HAVE_HARFBUZZ
+ hb_unicode_funcs_t *p_funcs = hb_unicode_funcs_get_default();
diff --git a/media-video/vlc/vlc-3.0.3-r1.ebuild b/media-video/vlc/vlc-3.0.3-r1.ebuild
index 3a76f2f5cf9d..f446a7144305 100644
--- a/media-video/vlc/vlc-3.0.3-r1.ebuild
+++ b/media-video/vlc/vlc-3.0.3-r1.ebuild
@@ -230,6 +230,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.2.8-freerdp-2.patch # bug 590164
"${FILESDIR}"/${PN}-3.0.1-qt-5.11.patch # TODO upstream
"${FILESDIR}"/${P}-fix-disable-vlm.patch # bug 649798
+ "${FILESDIR}"/${P}-fribidi-1.patch # bug 662662
)
DOCS=( AUTHORS THANKS NEWS README doc/fortunes.txt )