summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-05-09 12:27:19 +0200
committerFabian Groffen <grobian@gentoo.org>2020-05-09 12:27:26 +0200
commit8572bec1b953cb0fbdf348097b62b140208500cc (patch)
tree5acb500dc23c2a2ba444095b7630fbab1ca2a245 /net-analyzer/graphite-web
parentapp-text/coolreader: homepage updated (diff)
downloadgentoo-8572bec1b953cb0fbdf348097b62b140208500cc.tar.gz
gentoo-8572bec1b953cb0fbdf348097b62b140208500cc.tar.bz2
gentoo-8572bec1b953cb0fbdf348097b62b140208500cc.zip
net-analyzer/graphite-web-1.1.5-r1: add support for Python-3.7
Drop dep on scandir, as the built-in version from Python-3.5+ is tried first, so we don't need the dep (which additionally doesn't support Python-3.8 yet). Can't add support for Python-3.8 due to python-memcached. Bug: https://bugs.gentoo.org/718418 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'net-analyzer/graphite-web')
-rw-r--r--net-analyzer/graphite-web/graphite-web-1.1.5-r1.ebuild3
1 files changed, 1 insertions, 2 deletions
diff --git a/net-analyzer/graphite-web/graphite-web-1.1.5-r1.ebuild b/net-analyzer/graphite-web/graphite-web-1.1.5-r1.ebuild
index 3d688856dc87..35eb0f1c76f7 100644
--- a/net-analyzer/graphite-web/graphite-web-1.1.5-r1.ebuild
+++ b/net-analyzer/graphite-web/graphite-web-1.1.5-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_6 ) # 3.{7,8} dropped due to dep-hell
+PYTHON_COMPAT=( python3_{6,7} ) # 3.8 dropped due to dep on python-memcached
inherit distutils-r1 prefix
@@ -27,7 +27,6 @@ RDEPEND="
dev-python/cairocffi[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/scandir[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/urllib3[${PYTHON_USEDEP}]
media-libs/fontconfig