summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>2019-08-12 23:45:22 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-10-28 06:03:20 +0200
commit52c64f2720418a0a5724ac773524aaa7eaf6c73a (patch)
tree9f5f9c9e4d3bf978262f319b09162dbaf04bc10d /net-analyzer/gvm/gvm-10.0.1.ebuild
parentnet-analyzer/greenbone-security-assistant: bump to 8.0.1. (diff)
downloadgentoo-52c64f2720418a0a5724ac773524aaa7eaf6c73a.tar.gz
gentoo-52c64f2720418a0a5724ac773524aaa7eaf6c73a.tar.bz2
gentoo-52c64f2720418a0a5724ac773524aaa7eaf6c73a.zip
net-analyzer/gvm: new package.
Project name of OpenVAS with version 10 has been renamed in Greenbone Vulnerability Management (gvm). This is loader package of 'gvm' components. Version bump to 10.0.1. Also introduces the new USE flags 'cron','postgres','sqlite'. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Closes: https://bugs.gentoo.org/692004 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer/gvm/gvm-10.0.1.ebuild')
-rw-r--r--net-analyzer/gvm/gvm-10.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/gvm/gvm-10.0.1.ebuild b/net-analyzer/gvm/gvm-10.0.1.ebuild
new file mode 100644
index 000000000000..a1811d22fb5d
--- /dev/null
+++ b/net-analyzer/gvm/gvm-10.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Greenbone Vulnerability Management,previously named OpenVAS"
+HOMEPAGE="https://www.greenbone.net/en/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli +cron +extras +gsa ldap ospd postgres radius +sqlite"
+REQUIRED_USE="|| ( postgres sqlite )"
+
+RDEPEND="
+ >=net-analyzer/gvm-libs-10.0.1[extras?,ldap?,radius?]
+ >=net-analyzer/gvmd-8.0.1[extras?,postgres?,sqlite?]
+ ~net-analyzer/openvas-scanner-6.0.1[cron?,extras?]
+ !net-analyzer/openvas
+ cli? ( >=net-analyzer/gvm-tools-1.4.1 )
+ gsa? ( ~net-analyzer/greenbone-security-assistant-8.0.1[extras?] )
+ ospd? ( >=net-analyzer/ospd-1.3.2[extras?] )"
+
+pkg_postinst() {
+ elog "Additional support for extra checks can be get from"
+ optfeature "Web server scanning and testing tool" net-analyzer/nikto
+ optfeature "Portscanner" net-analyzer/nmap
+ optfeature "IPsec VPN scanning, fingerprinting and testing tool" net-analyzer/ike-scan
+ optfeature "Application protocol detection tool" net-analyzer/amap
+ optfeature "ovaldi (OVAL) — an OVAL Interpreter" app-forensics/ovaldi
+ optfeature "Linux-kernel-based portscanner" net-analyzer/portbunny
+ optfeature "Web application attack and audit framework" net-analyzer/w3af
+}