summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/ifstat/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/ifstat/files')
-rw-r--r--net-analyzer/ifstat/files/ifstat-1.1-hardened.patch11
-rw-r--r--net-analyzer/ifstat/files/ifstat-1.1-make.patch122
2 files changed, 133 insertions, 0 deletions
diff --git a/net-analyzer/ifstat/files/ifstat-1.1-hardened.patch b/net-analyzer/ifstat/files/ifstat-1.1-hardened.patch
new file mode 100644
index 000000000000..10c377ac7678
--- /dev/null
+++ b/net-analyzer/ifstat/files/ifstat-1.1-hardened.patch
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -58,7 +58,7 @@
+ /*) file=$with_proc; with_proc=yes ;;
+ *) file=/proc/net/dev
+ AC_MSG_CHECKING([for proc interface in $file])
+- if grep -q Inter- $file 2>/dev/null; then
++ if true; then
+ AC_DEFINE([USE_PROC], 1, [Define if you want to use /proc to get stats])
+ AC_DEFINE_UNQUOTED([PROC_FILE], ["$file"], [Proc file to poll for stats])
+ with_proc=yes
diff --git a/net-analyzer/ifstat/files/ifstat-1.1-make.patch b/net-analyzer/ifstat/files/ifstat-1.1-make.patch
new file mode 100644
index 000000000000..62feb8b0005a
--- /dev/null
+++ b/net-analyzer/ifstat/files/ifstat-1.1-make.patch
@@ -0,0 +1,122 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -65,14 +65,14 @@
+ install: install-$(TARGET) install-@LIBTARGET@
+
+ install-$(TARGET): $(TARGET)
+- $(INSTALL) -d -m 755 $(bindir)
+- $(INSTALL) -s -m 755 $(TARGET) $(bindir)/$(TARGET)
+- $(INSTALL) -d -m 755 $(mandir)/man1
+- $(INSTALL) -m 644 ifstat.1 $(mandir)/man1/ifstat.1
++ $(INSTALL) -d -m 755 $(DESTDIR)/$(bindir)
++ $(INSTALL) -m 755 $(TARGET) $(DESTDIR)/$(bindir)/$(TARGET)
++ $(INSTALL) -d -m 755 $(DESTDIR)/$(mandir)/man1
++ $(INSTALL) -m 644 ifstat.1 $(DESTDIR)/$(mandir)/man1/ifstat.1
+
+ install-$(LIBTARGET): $(LIBTARGET) libifstat-config
+- $(INSTALL) -d -m 755 $(bindir)
+- $(INSTALL) -m 755 libifstat-config $(bindir)/libifstat-config
++ $(INSTALL) -d -m 755 $(DESTDIR)/$(bindir)
++ $(INSTALL) -m 755 libifstat-config $(DESTDIR)/$(bindir)/libifstat-config
+ $(INSTALL) -d -m 755 $(includedir)
+ $(INSTALL) -m 644 ifstat.h $(includedir)/ifstat.h
+ $(INSTALL) -d -m 755 $(libdir)
+--- a/configure.in
++++ b/configure.in
+@@ -55,9 +55,8 @@
+ # checking for proc (Linux)
+ if test "x$with_proc" != "xno"; then
+ case "$with_proc" in
+- /*) file=$with_proc ;;
+- *) file=/proc/net/dev ;;
+- esac
++ /*) file=$with_proc; with_proc=yes ;;
++ *) file=/proc/net/dev
+ AC_MSG_CHECKING([for proc interface in $file])
+ if grep -q Inter- $file 2>/dev/null; then
+ AC_DEFINE([USE_PROC], 1, [Define if you want to use /proc to get stats])
+@@ -69,6 +68,8 @@
+ with_proc=no
+ fi
+ AC_MSG_RESULT([$with_proc])
++ ;;
++ esac
+ fi
+
+ # checking for kstat (Solaris)
+@@ -393,7 +394,7 @@
+ [snmp_ok=yes], [snmp_ok=no])
+ AC_MSG_RESULT([$snmp_ok])
+ if test "x$snmp_ok" = "xyes"; then
+- with_snmp=yes
++ use_snmp=yes
+ snmp_type=net
+ else
+ CPPFLAGS="$OCPPFLAGS"
+@@ -402,22 +403,22 @@
+ fi
+
+ if test "x$snmp_ok" != "xyes"; then
+- if test "x$with_snmp" != "xyes" ; then
++ if test "x$use_snmp" != "xyes" ; then
+ CPPFLAGS="$CPPFLAGS -I$with_snmp/include"
+ LDFLAGS="$LDFLAGS -L$with_snmp/lib"
+ fi
+ AC_CHECK_HEADER(net-snmp/net-snmp-config.h, snmp_type=net,
+ [AC_CHECK_HEADER(ucd-snmp/ucd-snmp-config.h,
+- snmp_type=ucd, with_snmp=no)])
++ snmp_type=ucd, use_snmp=no)])
+
+- if test "x$with_snmp" != "xno"; then
++ if test "x$use_snmp" != "xno"; then
+ if test "x$snmp_type" = "xnet"; then
+ libsnmp="-lnetsnmp"
+ else
+ libsnmp="-lsnmp"
+ fi
+
+- with_snmp=no
++ use_snmp=no
+ SNMPLIBALONE="$libsnmp"
+ # Setting to be able to force linking with -lcrypto....
+ # This is needed on OpenBSD (at least) where the snmplib port links without -lcrypto,
+@@ -429,18 +430,18 @@
+ SNMPLIBALONE=""
+ fi
+ for lib in $SNMPLIBALONE "$libsnmp -lcrypto" ; do
+- if test "x$with_snmp" != "xyes" ; then
++ if test "x$use_snmp" != "xyes" ; then
+ AC_MSG_CHECKING([for snmp support in $lib])
+ OLIBS="$LIBS"
+ LIBS="$LIBS $lib"
+ AC_TRY_LINK([], [snmp_sess_init();],
+- [with_snmp=yes], [LIBS="$OLIBS"])
+- AC_MSG_RESULT([$with_snmp])
++ [use_snmp=yes], [LIBS="$OLIBS"])
++ AC_MSG_RESULT([$use_snmp])
+ fi
+ done
+ fi
+ fi
+- if test "x$with_snmp" = "xyes" ; then
++ if test "x$use_snmp" = "xyes" ; then
+ AC_DEFINE([USE_SNMP], 1, [Define if you have SNMP support])
+ if test "x$snmp_type" = "xnet"; then
+ AC_DEFINE([HAVE_NET_SNMP], 1,
+@@ -464,10 +465,13 @@
+
+ # checking that we do have at least one driver
+ if test "x$local" != "xyes"; then
++ AC_MSG_WARN([no native stats gathering mechanism found; will use SNMP.])
+ if test "x$with_snmp" = "xyes"; then
+- AC_MSG_WARN([no native stats gathering mechanism found; will use SNMP.])
+- else
+- AC_MSG_ERROR([no statistics gathering methods found, porting needed.])
++ if test "x$use_snmp" = "xno"; then
++ AC_MSG_ERROR([net-snmp requested but not found.])
++ else
++ AC_MSG_ERROR([no statistics gathering methods found, porting needed.])
++ fi
+ fi
+ fi
+