summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-01-11 22:07:22 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-01-11 22:10:05 +0100
commitbff4a82e074ac7b7a8ed0b6d733ff9c247cdae26 (patch)
tree7b2434501fe4383075ace437189fa3fee4068038 /net-analyzer/jnettop/jnettop-0.13.0-r2.ebuild
parentnet-analyzer/mrtg-ping-probe: Port to EAPI 8 (diff)
downloadgentoo-bff4a82e074ac7b7a8ed0b6d733ff9c247cdae26.tar.gz
gentoo-bff4a82e074ac7b7a8ed0b6d733ff9c247cdae26.tar.bz2
gentoo-bff4a82e074ac7b7a8ed0b6d733ff9c247cdae26.zip
net-analyzer/jnettop: Port to EAPI 8
Closes: https://bugs.gentoo.org/826814 Closes: https://bugs.gentoo.org/738074 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-analyzer/jnettop/jnettop-0.13.0-r2.ebuild')
-rw-r--r--net-analyzer/jnettop/jnettop-0.13.0-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/jnettop/jnettop-0.13.0-r2.ebuild b/net-analyzer/jnettop/jnettop-0.13.0-r2.ebuild
new file mode 100644
index 000000000000..f94cbf95ae1c
--- /dev/null
+++ b/net-analyzer/jnettop/jnettop-0.13.0-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A top like console network traffic visualiser"
+HOMEPAGE="https://sourceforge.net/projects/jnettop"
+SRC_URI="http://jnettop.kubs.info/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="berkdb ncurses syslog"
+
+RDEPEND="
+ net-libs/libpcap
+ >=dev-libs/glib-2.0.1
+ berkdb? ( =sys-libs/db-4* )
+ ncurses? ( sys-libs/ncurses )
+ syslog? ( virtual/logger )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-asneeded.patch"
+ "${FILESDIR}/${P}-tinfo.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ncurses) \
+ $(use_with berkdb db4) \
+ $(use_with syslog)
+}
+
+src_install() {
+ default
+ newdoc .${PN} ${PN}.dotfile
+}