summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-28 18:44:53 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-28 18:59:34 -0500
commitd7b3bf2ee1c173f694d93bf46155576349fbcf4c (patch)
tree7a5dd689d85b41be941ec2c847ef8db955cc7ffe /net-analyzer/synscan
parentwww-client/vivaldi-snapshot: Drop old 5.6.2839.3 (diff)
downloadgentoo-d7b3bf2ee1c173f694d93bf46155576349fbcf4c.tar.gz
gentoo-d7b3bf2ee1c173f694d93bf46155576349fbcf4c.tar.bz2
gentoo-d7b3bf2ee1c173f694d93bf46155576349fbcf4c.zip
net-analyzer/synscan: EAPI7->8, fix w/ lld
Closes: https://bugs.gentoo.org/875017 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-analyzer/synscan')
-rw-r--r--net-analyzer/synscan/files/synscan-5.02-lld.patch9
-rw-r--r--net-analyzer/synscan/synscan-5.02.ebuild10
2 files changed, 14 insertions, 5 deletions
diff --git a/net-analyzer/synscan/files/synscan-5.02-lld.patch b/net-analyzer/synscan/files/synscan-5.02-lld.patch
new file mode 100644
index 000000000000..612e91599984
--- /dev/null
+++ b/net-analyzer/synscan/files/synscan-5.02-lld.patch
@@ -0,0 +1,9 @@
+lld does not ignore erroneous libdirs (ideally should use pkg-config)
+https://bugs.gentoo.org/875017
+--- a/configure.in
++++ b/configure.in
+@@ -60,3 +60,3 @@
+ CFLAGS="$CFLAGS -I${prefix}/include"
+- LIBS="$LIBS -L${prefix}/lib -lpcap"
++ LIBS="$LIBS -lpcap"
+ elif test -f /usr/include/pcap/pcap.h; then
diff --git a/net-analyzer/synscan/synscan-5.02.ebuild b/net-analyzer/synscan/synscan-5.02.ebuild
index d8b2dba2efc9..5d38f8710526 100644
--- a/net-analyzer/synscan/synscan-5.02.ebuild
+++ b/net-analyzer/synscan/synscan-5.02.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
-DESCRIPTION="A fast asynchronous half-open TCP portscanner"
+DESCRIPTION="Fast asynchronous half-open TCP portscanner"
HOMEPAGE="http://www.digit-labs.org/files/tools/synscan/"
-SRC_URI="http://www.digit-labs.org/files/tools/${PN}/releases/${P}.tar.gz"
+SRC_URI="http://www.digit-labs.org/files/tools/synscan/releases/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 x86 ~x64-macos"
@@ -18,12 +18,12 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-destdir.patch
+ "${FILESDIR}"/${P}-lld.patch
)
src_prepare() {
default
- mv configure.{in,ac} || die
eautoreconf
}