summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/traceroute-nanog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/traceroute-nanog')
-rw-r--r--net-analyzer/traceroute-nanog/Manifest2
-rw-r--r--net-analyzer/traceroute-nanog/metadata.xml5
-rw-r--r--net-analyzer/traceroute-nanog/traceroute-nanog-6.4.2-r1.ebuild40
3 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/traceroute-nanog/Manifest b/net-analyzer/traceroute-nanog/Manifest
new file mode 100644
index 000000000000..f793936728f6
--- /dev/null
+++ b/net-analyzer/traceroute-nanog/Manifest
@@ -0,0 +1,2 @@
+DIST traceroute-nanog_6.4.2-1.diff.gz 18417 SHA256 840f517113cfc03cc708a7e58ef091b464f4876507488ea072df078795b8346b SHA512 62c2df3db292ab263a2d076689b80ff156bd4a3b4f604974ad8210a700bee80055e21165909eeff138d03570ffe4a44b983ed0cf5ba0c6a914af1928ae82038e WHIRLPOOL 8f6fa7b062cade6c1c3a594a46f31aaec9b40ed2653fe371dc83b97e7012041969f55690365fea070fb09c06b43fbc03ab80d5cea53580da9d531a33fbde46b7
+DIST traceroute-nanog_6.4.2.orig.tar.gz 34429 SHA256 86def604ea95df7c0b6787f6b3e41b10feab0756e16b49a7d2aeab9b02199168 SHA512 1cd4c98404e7b25b2c1f1e4018fc1774f09822df8e597022c7b31b9cf20ce3c5649fd90337c62c65d163fb9c896bd9e19277febb5312d4afe347eac328c6e304 WHIRLPOOL 90c095acb11240089636e4f3258678914fb9bd845ff602326e3eb605ba67be14e8b9525b4c9895edf650063f900d21df0fadd2df418f2aab10466bb4a78a1f31
diff --git a/net-analyzer/traceroute-nanog/metadata.xml b/net-analyzer/traceroute-nanog/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/traceroute-nanog/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/traceroute-nanog/traceroute-nanog-6.4.2-r1.ebuild b/net-analyzer/traceroute-nanog/traceroute-nanog-6.4.2-r1.ebuild
new file mode 100644
index 000000000000..6cf308b644ae
--- /dev/null
+++ b/net-analyzer/traceroute-nanog/traceroute-nanog-6.4.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}_${PV}"
+DEB_PL="1"
+DESCRIPTION="Traceroute with AS lookup, TOS support, MTU discovery and other features"
+HOMEPAGE="http://packages.debian.org/traceroute-nanog"
+SRC_URI="
+ http://dev.gentoo.org/~jer/${MY_P}.orig.tar.gz
+ http://dev.gentoo.org/~jer/${MY_P}-${DEB_PL}.diff.gz
+"
+RESTRICT="mirror"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+S="${S}.orig"
+
+src_prepare() {
+ EPATCH_SUFFIX="dpatch" epatch \
+ "${WORKDIR}/${MY_P}-${DEB_PL}.diff" \
+ "${WORKDIR}/${P}.orig/${P}/debian/patches/"
+}
+
+src_compile() {
+ $(tc-getCC) traceroute.c -o ${PN} ${CFLAGS} -DSTRING ${LDFLAGS} -lresolv -lm \
+ || die
+}
+
+src_install() {
+ dosbin traceroute-nanog
+ dodoc 0_readme.txt faq.txt
+ newman ${P}/debian/traceroute-nanog.genuine.8 traceroute-nanog.8
+}