summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 00:02:55 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:59 +0100
commitafbf9a0c6207949abd1e601d6d1c26b17df4eae2 (patch)
tree6bedfc796a4dd0245598a696d62d66757b718f54 /net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
parentnet-analyzer/vnstat: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-afbf9a0c6207949abd1e601d6d1c26b17df4eae2.tar.gz
gentoo-afbf9a0c6207949abd1e601d6d1c26b17df4eae2.tar.bz2
gentoo-afbf9a0c6207949abd1e601d6d1c26b17df4eae2.zip
net-analyzer/zabbix: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild')
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild b/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
index c94739cfae13..b8d35f5a7591 100644
--- a/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
@@ -557,6 +557,8 @@ pkg_postinst() {
fi
if use server; then
+ tmpfiles_process zabbix-server.conf
+
elog
elog "For distributed monitoring you have to run:"
elog
@@ -567,6 +569,18 @@ pkg_postinst() {
elog
fi
+ if use proxy; then
+ tmpfiles_process zabbix-proxy.conf
+ fi
+
+ if use agent; then
+ tmpfiles_process zabbix-agentd.conf
+ fi
+
+ if use agent2; then
+ tmpfiles_process zabbix-agent2.conf
+ fi
+
elog "--"
elog
elog "You may need to add these lines to /etc/services:"