summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2024-04-04 01:25:22 +0200
committerLouis Sautier <sbraz@gentoo.org>2024-04-04 02:17:38 +0200
commit092162771d51a14486411f5e3de0f5803ccfbe2a (patch)
treeb5e8a51bf196b2028637c2d7d9c15fd9bee10677 /net-analyzer
parentx11-base/xorg-server: Version bump to 21.1.12 (diff)
downloadgentoo-092162771d51a14486411f5e3de0f5803ccfbe2a.tar.gz
gentoo-092162771d51a14486411f5e3de0f5803ccfbe2a.tar.bz2
gentoo-092162771d51a14486411f5e3de0f5803ccfbe2a.zip
net-analyzer/nagios-plugins-linux-madrisan: add 33
The varlink dependency and check_varlink were removed in https://github.com/madrisan/nagios-plugins-linux/commit/c57ceb58139a. USE=curl now controls the creation of check_container (renamed from check_docker in https://github.com/madrisan/nagios-plugins-linux/commit/492741a80d29). Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-plugins-linux-madrisan/Manifest1
-rw-r--r--net-analyzer/nagios-plugins-linux-madrisan/metadata.xml2
-rw-r--r--net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-33.ebuild48
3 files changed, 50 insertions, 1 deletions
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/Manifest b/net-analyzer/nagios-plugins-linux-madrisan/Manifest
index c5a6cee5a49f..b3b7c1490f2a 100644
--- a/net-analyzer/nagios-plugins-linux-madrisan/Manifest
+++ b/net-analyzer/nagios-plugins-linux-madrisan/Manifest
@@ -1,2 +1,3 @@
DIST nagios-plugins-linux-madrisan-31.tar.xz 401556 BLAKE2B 5eca1e96f14b518d9ab5304bb2a54ba47f194bf22cea8445d7fef0769c3b14c800e4ed24c5c0ca32f0daf53aa81a0bd52234478c606a8d2d1a12e96abb90179c SHA512 34d8ae400766e9c7ddd246998f004a50c87ec9ad8dc13deb8e31fc6fcfa07fbe5af2f091d0523b93d06b26438d1a25240bd82d60946e5897bc257fff7c1b73d0
DIST nagios-plugins-linux-madrisan-32.tar.xz 402976 BLAKE2B ef66934315f3ddbee1a2d84723477773549c9a5ed731853780ef15b9f44ea462256f730f854d517415dce2b944a4bf0abcbfa0623a7a1faffef4b5bbf162af76 SHA512 42392c123961bb17192344f20973a3d26c74aeef112638384d5b7a687e7117a3378d6efdb07ad15a7309f5db621404602e9c2beb0dcc4e207924d0d3a466ab59
+DIST nagios-plugins-linux-madrisan-33.tar.xz 397516 BLAKE2B 39e428d7b44104e01f8101ec33d250b8317c2ab9a5772bd815baf91c14eb1aeffc2aaaec1696e338d9aa31ebd9cb67d10a2049bc78a1bd8fea813761def36d26 SHA512 9b0df712d799ea5ae1eca8135089e41f167446e40416dbfe090ec855476318b26d8fdc3865470bf6cf54e7dcbce483d1f577a886ef35023e983e2508a307df70
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/metadata.xml b/net-analyzer/nagios-plugins-linux-madrisan/metadata.xml
index c214125e5675..e1a109026d7c 100644
--- a/net-analyzer/nagios-plugins-linux-madrisan/metadata.xml
+++ b/net-analyzer/nagios-plugins-linux-madrisan/metadata.xml
@@ -6,7 +6,7 @@
<name>Louis Sautier</name>
</maintainer>
<use>
- <flag name="curl">Build check_docker which requires <pkg>net-misc/curl</pkg></flag>
+ <flag name="curl">Build check_container which requires <pkg>net-misc/curl</pkg></flag>
<flag name="varlink">Build check_podman which requires <pkg>dev-libs/libvarlink</pkg></flag>
</use>
<upstream>
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-33.ebuild b/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-33.ebuild
new file mode 100644
index 000000000000..4e7690db9073
--- /dev/null
+++ b/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-33.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN="nagios-plugins-linux"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Additional and alternative Nagios plugins for Linux"
+HOMEPAGE="https://github.com/madrisan/nagios-plugins-linux"
+SRC_URI="https://github.com/madrisan/${MY_PN}/releases/download/v${PV}/${MY_P}.tar.xz -> ${P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl systemd"
+
+DEPEND="
+ curl? ( net-misc/curl:0= )
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ # Avoid collision with net-analyzer/monitoring-plugins
+ # and net-analyzer/nagios-plugins
+ sed -ri "s/check_(load|swap|uptime|users)/&_madrisan/" plugins/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)/nagios/plugins"
+ # Most options are already defaults for Gentoo
+ --disable-hardening
+ $(use_enable curl libcurl)
+ $(use_enable systemd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake check VERBOSE=1
+}