summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-08-23 18:32:51 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2023-08-23 18:48:46 +0200
commit0a38c2aa42c8b69efb99c6e919a17b67143d087e (patch)
tree0cdf8951d1318776a4d5efb7cca62f51f4811a33 /net-analyzer
parentsys-devel/mold: keyword 2.1.0 for ~loong (diff)
downloadgentoo-0a38c2aa42c8b69efb99c6e919a17b67143d087e.tar.gz
gentoo-0a38c2aa42c8b69efb99c6e919a17b67143d087e.tar.bz2
gentoo-0a38c2aa42c8b69efb99c6e919a17b67143d087e.zip
net-analyzer/zabbix: when compiling with agent2, prohibit gnutls
agent2 supports only openssl whereas the other modules support also gnutls - it would be better to still allow gnutls for other modules and force use of openssl only for agent2 (in fact https://www.zabbix.com/documentation/current/en/manual/encryption mentions it should be possible but does not show how) but that would need to find out how to do that (probably splitting agent2 to a separate package would be the solution) Closes: https://bugs.gentoo.org/909362 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.35.ebuild1
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.36.ebuild1
-rw-r--r--net-analyzer/zabbix/zabbix-6.0.18.ebuild1
-rw-r--r--net-analyzer/zabbix/zabbix-6.0.19.ebuild1
-rw-r--r--net-analyzer/zabbix/zabbix-6.0.20.ebuild1
-rw-r--r--net-analyzer/zabbix/zabbix-6.4.3.ebuild1
-rw-r--r--net-analyzer/zabbix/zabbix-6.4.4.ebuild1
-rw-r--r--net-analyzer/zabbix/zabbix-6.4.5.ebuild1
8 files changed, 8 insertions, 0 deletions
diff --git a/net-analyzer/zabbix/zabbix-5.0.35.ebuild b/net-analyzer/zabbix/zabbix-5.0.35.ebuild
index 8917235a56d0..a71802cf2bf6 100644
--- a/net-analyzer/zabbix/zabbix-5.0.35.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.35.ebuild
@@ -28,6 +28,7 @@ KEYWORDS="amd64 x86"
IUSE="+agent +agent2 curl frontend gnutls ipv6 java ldap libxml2 mysql odbc openipmi +openssl oracle +postgres proxy selinux server snmp sqlite ssh static"
REQUIRED_USE="|| ( agent agent2 frontend proxy server )
?? ( gnutls openssl )
+ agent2 ( !gnutls )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) !sqlite )
static? ( !oracle !snmp )"
diff --git a/net-analyzer/zabbix/zabbix-5.0.36.ebuild b/net-analyzer/zabbix/zabbix-5.0.36.ebuild
index ec1e25bbcd14..cc4546e6cb45 100644
--- a/net-analyzer/zabbix/zabbix-5.0.36.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.36.ebuild
@@ -28,6 +28,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="+agent +agent2 curl frontend gnutls ipv6 java ldap libxml2 mysql odbc openipmi +openssl oracle +postgres proxy selinux server snmp sqlite ssh static"
REQUIRED_USE="|| ( agent agent2 frontend proxy server )
?? ( gnutls openssl )
+ agent2 ( !gnutls )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) !sqlite )
static? ( !oracle !snmp )"
diff --git a/net-analyzer/zabbix/zabbix-6.0.18.ebuild b/net-analyzer/zabbix/zabbix-6.0.18.ebuild
index b48c28cb2ee3..6d18d732cf90 100644
--- a/net-analyzer/zabbix/zabbix-6.0.18.ebuild
+++ b/net-analyzer/zabbix/zabbix-6.0.18.ebuild
@@ -28,6 +28,7 @@ KEYWORDS="amd64 x86"
IUSE="agent +agent2 curl frontend gnutls ipv6 java ldap libxml2 mysql odbc openipmi +openssl oracle +postgres proxy selinux server snmp sqlite ssh static"
REQUIRED_USE="|| ( agent agent2 frontend proxy server )
?? ( gnutls openssl )
+ agent2 ( !gnutls )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) !sqlite )
static? ( !oracle !snmp )"
diff --git a/net-analyzer/zabbix/zabbix-6.0.19.ebuild b/net-analyzer/zabbix/zabbix-6.0.19.ebuild
index e5e5f002a22e..4da32a57da4b 100644
--- a/net-analyzer/zabbix/zabbix-6.0.19.ebuild
+++ b/net-analyzer/zabbix/zabbix-6.0.19.ebuild
@@ -28,6 +28,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="agent +agent2 curl frontend gnutls ipv6 java ldap libxml2 mysql odbc openipmi +openssl oracle +postgres proxy selinux server snmp sqlite ssh static"
REQUIRED_USE="|| ( agent agent2 frontend proxy server )
?? ( gnutls openssl )
+ agent2 ( !gnutls )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) !sqlite )
static? ( !oracle !snmp )"
diff --git a/net-analyzer/zabbix/zabbix-6.0.20.ebuild b/net-analyzer/zabbix/zabbix-6.0.20.ebuild
index e5e5f002a22e..4da32a57da4b 100644
--- a/net-analyzer/zabbix/zabbix-6.0.20.ebuild
+++ b/net-analyzer/zabbix/zabbix-6.0.20.ebuild
@@ -28,6 +28,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="agent +agent2 curl frontend gnutls ipv6 java ldap libxml2 mysql odbc openipmi +openssl oracle +postgres proxy selinux server snmp sqlite ssh static"
REQUIRED_USE="|| ( agent agent2 frontend proxy server )
?? ( gnutls openssl )
+ agent2 ( !gnutls )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) !sqlite )
static? ( !oracle !snmp )"
diff --git a/net-analyzer/zabbix/zabbix-6.4.3.ebuild b/net-analyzer/zabbix/zabbix-6.4.3.ebuild
index 239652c7407d..4c6a9f5a4fcc 100644
--- a/net-analyzer/zabbix/zabbix-6.4.3.ebuild
+++ b/net-analyzer/zabbix/zabbix-6.4.3.ebuild
@@ -28,6 +28,7 @@ KEYWORDS="amd64 x86"
IUSE="agent +agent2 curl frontend gnutls ipv6 java ldap libxml2 mysql odbc openipmi +openssl oracle +postgres proxy selinux server snmp sqlite ssh static"
REQUIRED_USE="|| ( agent agent2 frontend proxy server )
?? ( gnutls openssl )
+ agent2 ( !gnutls )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) !sqlite )
static? ( !oracle !snmp )"
diff --git a/net-analyzer/zabbix/zabbix-6.4.4.ebuild b/net-analyzer/zabbix/zabbix-6.4.4.ebuild
index 2423117090ed..38f6609f2faf 100644
--- a/net-analyzer/zabbix/zabbix-6.4.4.ebuild
+++ b/net-analyzer/zabbix/zabbix-6.4.4.ebuild
@@ -28,6 +28,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="agent +agent2 curl frontend gnutls ipv6 java ldap libxml2 mysql odbc openipmi +openssl oracle +postgres proxy selinux server snmp sqlite ssh static"
REQUIRED_USE="|| ( agent agent2 frontend proxy server )
?? ( gnutls openssl )
+ agent2 ( !gnutls )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) !sqlite )
static? ( !oracle !snmp )"
diff --git a/net-analyzer/zabbix/zabbix-6.4.5.ebuild b/net-analyzer/zabbix/zabbix-6.4.5.ebuild
index 2423117090ed..38f6609f2faf 100644
--- a/net-analyzer/zabbix/zabbix-6.4.5.ebuild
+++ b/net-analyzer/zabbix/zabbix-6.4.5.ebuild
@@ -28,6 +28,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="agent +agent2 curl frontend gnutls ipv6 java ldap libxml2 mysql odbc openipmi +openssl oracle +postgres proxy selinux server snmp sqlite ssh static"
REQUIRED_USE="|| ( agent agent2 frontend proxy server )
?? ( gnutls openssl )
+ agent2 ( !gnutls )
proxy? ( ^^ ( mysql oracle postgres sqlite ) )
server? ( ^^ ( mysql oracle postgres ) !sqlite )
static? ( !oracle !snmp )"