summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2024-10-05 22:33:51 +0200
committerSam James <sam@gentoo.org>2024-10-06 11:49:45 +0100
commit156b823069228e48099bb2894b18ea1ec944e0c6 (patch)
treeb1d98b93eeb231d6fb0f3589bf69bf8647cbfd94 /net-analyzer
parentx11-misc/i3blocks: Stabilize 1.5-r2 x86, #940940 (diff)
downloadgentoo-156b823069228e48099bb2894b18ea1ec944e0c6.tar.gz
gentoo-156b823069228e48099bb2894b18ea1ec944e0c6.tar.bz2
gentoo-156b823069228e48099bb2894b18ea1ec944e0c6.zip
net-analyzer/wireshark: fix build with USE=doc
As it turns out the build works the way it does, not the way I thought it did. Now it works for either -doc/+doc. Closes: https://bugs.gentoo.org/940910 Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/38888 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/wireshark-4.4.0.ebuild10
-rw-r--r--net-analyzer/wireshark/wireshark-9999.ebuild10
2 files changed, 12 insertions, 8 deletions
diff --git a/net-analyzer/wireshark/wireshark-4.4.0.ebuild b/net-analyzer/wireshark/wireshark-4.4.0.ebuild
index f82761643441..10ae13f0a233 100644
--- a/net-analyzer/wireshark/wireshark-4.4.0.ebuild
+++ b/net-analyzer/wireshark/wireshark-4.4.0.ebuild
@@ -266,10 +266,10 @@ src_install() {
# https://gitlab.com/wireshark/wireshark/-/commit/fe7bfdf6caac9204ab5f34eeba7b0f4a0314d3cd
cmake_src_install install-headers
- # prepare Relase Notes redirector if necessary (bug #939195)
- local relnotes="doc/release-notes.html"
-
if ! use doc; then
+ # prepare Relase Notes redirector (bug #939195)
+ local relnotes="doc/release-notes.html"
+
# by default create a link for our specific version
local relversion="wireshark-${PV}.html"
@@ -278,11 +278,13 @@ src_install() {
relversion=""
fi
+ # patch version into redirector & install it
sed -e "s/#VERSION#/${relversion}/g" < "${FILESDIR}/release-notes.html" > ${relnotes} || die
+ dodoc ${relnotes}
fi
# FAQ is not required as is installed from help/faq.txt
- dodoc AUTHORS ChangeLog README* doc/randpkt.txt doc/README* ${relnotes}
+ dodoc AUTHORS ChangeLog README* doc/randpkt.txt doc/README*
# install headers
insinto /usr/include/wireshark
diff --git a/net-analyzer/wireshark/wireshark-9999.ebuild b/net-analyzer/wireshark/wireshark-9999.ebuild
index 8e531a1680b6..5c5d9c7af028 100644
--- a/net-analyzer/wireshark/wireshark-9999.ebuild
+++ b/net-analyzer/wireshark/wireshark-9999.ebuild
@@ -264,10 +264,10 @@ src_install() {
# https://gitlab.com/wireshark/wireshark/-/commit/fe7bfdf6caac9204ab5f34eeba7b0f4a0314d3cd
cmake_src_install install-headers
- # prepare Relase Notes redirector if necessary (bug #939195)
- local relnotes="doc/release-notes.html"
-
if ! use doc; then
+ # prepare Relase Notes redirector (bug #939195)
+ local relnotes="doc/release-notes.html"
+
# by default create a link for our specific version
local relversion="wireshark-${PV}.html"
@@ -276,11 +276,13 @@ src_install() {
relversion=""
fi
+ # patch version into redirector & install it
sed -e "s/#VERSION#/${relversion}/g" < "${FILESDIR}/release-notes.html" > ${relnotes} || die
+ dodoc ${relnotes}
fi
# FAQ is not required as is installed from help/faq.txt
- dodoc AUTHORS ChangeLog README* doc/randpkt.txt doc/README* ${relnotes}
+ dodoc AUTHORS ChangeLog README* doc/randpkt.txt doc/README*
# install headers
insinto /usr/include/wireshark