summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorktrace@yandex.ru <ktrace@yandex.ru>2021-06-06 21:57:20 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-06-07 08:19:50 +0300
commit4fbf9f4effb630645e5d64809a24e376099f2c30 (patch)
treedd6f6a9c48ee3a3de6a37b5081d1a75130405b6d /net-dns/maradns
parentdev-ruby/ruby_parser: add 3.16.0 (diff)
downloadgentoo-4fbf9f4effb630645e5d64809a24e376099f2c30.tar.gz
gentoo-4fbf9f4effb630645e5d64809a24e376099f2c30.tar.bz2
gentoo-4fbf9f4effb630645e5d64809a24e376099f2c30.zip
net-dns/maradns: version bump to 3.5.0020 and fixes
- fix ipv6/noipv6 building Deadwood - still fixes compile flags - small change in doc's installing Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Victor Kustov <ktrace@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/21060 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-dns/maradns')
-rw-r--r--net-dns/maradns/Manifest1
-rw-r--r--net-dns/maradns/files/maradns-3.5.0020-flags-ipv6.patch113
-rw-r--r--net-dns/maradns/maradns-3.5.0020.ebuild96
3 files changed, 210 insertions, 0 deletions
diff --git a/net-dns/maradns/Manifest b/net-dns/maradns/Manifest
index 3dc055a4f473..0483ddcd84fc 100644
--- a/net-dns/maradns/Manifest
+++ b/net-dns/maradns/Manifest
@@ -1 +1,2 @@
DIST maradns-3.5.0005.tar.xz 5351412 BLAKE2B c6b1c4fb93cb507045b3c09574d7ce30b0af92301e157216b4a5bbd2ed74ceb829ef4d11cd08048c7a685a09cdd4178cf3fc4e7b2465820d26d3a5c1b96f4a5e SHA512 2e7008ff6217929008292dde60d96eb2ec0499a170e1b5bda5fcfb27300d2ce6cecd8b3e2a2d4b09ff32b803f9f435230378e6b2e41e7b63c42653d8c931151d
+DIST maradns-3.5.0020.tar.xz 7154452 BLAKE2B 4d193c06620332b90f4a004e787f9cbe61cd48adcee1dd667ecf0383c0fb81f5b7cae40ee953f077b2ccf060d7429863f741cf942c34c862d6c56092bc40600b SHA512 3478ccdc82d5be45826072f91c1b00c491f21f69bcce169cfeb3dfdd00e0012a9def884d711daa41ea18dce52e069dbb4c31e1e37ecda418565b5d8d6a0ea4d4
diff --git a/net-dns/maradns/files/maradns-3.5.0020-flags-ipv6.patch b/net-dns/maradns/files/maradns-3.5.0020-flags-ipv6.patch
new file mode 100644
index 000000000000..4582dec4f56a
--- /dev/null
+++ b/net-dns/maradns/files/maradns-3.5.0020-flags-ipv6.patch
@@ -0,0 +1,113 @@
+From 0a2159798edffdbc0fdba67b2ae4aeca118a2516 Mon Sep 17 00:00:00 2001
+From: Victor Kustov <ktrace@yandex.ru>
+Date: Mon, 31 May 2021 22:47:55 +0300
+Subject: [PATCH] fix
+
+---
+ build/Makefile.linux | 52 ++++++++++++++++++++++----------------------
+ configure | 4 ++--
+ 2 files changed, 28 insertions(+), 28 deletions(-)
+
+diff --git a/build/Makefile.linux b/build/Makefile.linux
+index 965c7fb..62c20b9 100644
+--- a/build/Makefile.linux
++++ b/build/Makefile.linux
+@@ -24,48 +24,48 @@ EXECS=server/maradns
+ # end the Solaris section
+ # Non-Solaris version of "M"
+ V="VERSION=$(VERSION)"
+-Q="DEFINES=-DSELECT_PROBLEM"
++Q="$(LDFLAGS) DEFINES=-DSELECT_PROBLEM"
+
+ # Debug
+
+ FLAGS = -O2 -Wall -DSELECT_PROBLEM
+-M="CC=$(CC) $(FLAGS)"
+-D="CC=$(CC) $(FLAGS) -DDEBUG -DTHREADS"
++M="CC=$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)"
++D="CC=$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -DDEBUG -DTHREADS"
+ #FLAGS = -g
+
+ all:
+- cd libs ; make $(M) ; cd ../dns ; make $(M) ; \
+- cd ../rng ; make $(M) ; cd ../parse ; make $(M) ; \
+- cd ../qual ; make $(M) ; cd ../server ; \
++ cd libs ; $(MAKE) $(M) ; cd ../dns ; $(MAKE) $(M) ; \
++ cd ../rng ; $(MAKE) $(M) ; cd ../parse ; $(MAKE) $(M) ; \
++ cd ../qual ; $(MAKE) $(M) ; cd ../server ; \
+ make $(M) $(V) COMPILED=\"$(COMPILED)\" ; \
+- cd ../tools ; make $(M) ; \
+- cd ../deadwood-*/src/ ; make FLAGS=-O2 ; \
+- cd ../../tcp ; make $(M) $(V) ; cat ../00README.FIRST
++ cd ../tools ; $(MAKE) $(M) ; \
++ cd ../deadwood-*/src/ ; $(MAKE) $(M) ; \
++ cd ../../tcp ; $(MAKE) $(M) $(V) ; cat ../00README.FIRST
+
+ debug:
+- cd libs ; make $(D) DEBUG="-DDEBUG -DTHREADS" ; \
+- cd ../dns ; make $(D) ; cd ../rng ; make $(D) ; \
+- cd ../parse ; make $(D) ; cd ../qual ; make $(D) ; \
++ cd libs ; $(MAKE) $(D) DEBUG="-DDEBUG -DTHREADS" ; \
++ cd ../dns ; $(MAKE) $(D) ; cd ../rng ; $(MAKE) $(D) ; \
++ cd ../parse ; $(MAKE) $(D) ; cd ../qual ; $(MAKE) $(D) ; \
+ cd ../server ; \
+ make $(D) $(Q) $(V) COMPILED=\"$(COMPILED_DEBUG)\" ; \
+- cd ../tools ; make $(D) ; \
+- cd ../tcp ; make $(D) $(V) ; cat ../00README.FIRST
++ cd ../tools ; $(MAKE) $(D) ; \
++ cd ../tcp ; $(MAKE) $(D) $(V) ; cat ../00README.FIRST
+
+ clean:
+ rm -f $(OBJECTS) core $(EXECS) ; \
+- cp build/Makefile.w Makefile ; cd dns ; make clean ; \
+- cd ../libs ; make clean ; cd ../parse ; make clean ; \
+- cd ../qual ; make clean ; \
+- cd ../server ; make clean ; \
++ cp build/Makefile.w Makefile ; cd dns ; $(MAKE) clean ; \
++ cd ../libs ; $(MAKE) clean ; cd ../parse ; $(MAKE) clean ; \
++ cd ../qual ; $(MAKE) clean ; \
++ cd ../server ; $(MAKE) clean ; \
+ cp Makefile.recursive Makefile ; \
+- cd ../test ; make clean ; \
+- cd ../tools ; make clean ; \
+- cd misc ; make clean ; \
+- cd ../../utf8 ; make clean ; \
+- cd ../tcp ; make clean ; \
+- cd ../rng ; make clean ; \
+- cd ../sqa ; make clean ; \
+- cd ../deadwood-*/src ; make clean ; \
++ cd ../test ; $(MAKE) clean ; \
++ cd ../tools ; $(MAKE) clean ; \
++ cd misc ; $(MAKE) clean ; \
++ cd ../../utf8 ; $(MAKE) clean ; \
++ cd ../tcp ; $(MAKE) clean ; \
++ cd ../rng ; $(MAKE) clean ; \
++ cd ../sqa ; $(MAKE) clean ; \
++ cd ../deadwood-*/src ; $(MAKE) clean ; \
+ # ; cd .. ; find . -type d | grep .deps | xargs rm -fr ; find . -name '*.o' | xargs rm
+
+ strip:
+diff --git a/configure b/configure
+index 9e98ac8..fedbd87 100755
+--- a/configure
++++ b/configure
+@@ -174,14 +174,14 @@ if [ -z "$IPV6" ] ; then
+ cp tcp/Makefile.authonly tcp/Makefile
+ cp dns/Makefile.authonly dns/Makefile
+ cp tools/Makefile.authonly tools/Makefile
++ DEADWOOD_DIR=$( echo deadwood-* )
++ cp $DEADWOOD_DIR/src/Makefile.noipv6 $DEADWOOD_DIR/src/Makefile
+ else
+ cp server/Makefile.ipv6 server/Makefile
+ cp qual/Makefile.nothreads qual/Makefile
+ cp tcp/Makefile.ipv6 tcp/Makefile
+ cp dns/Makefile.authonly dns/Makefile
+ cp tools/Makefile.ipv6 tools/Makefile
+- DEADWOOD_DIR=$( echo deadwood-* )
+- cp $DEADWOOD_DIR/src/Makefile.ipv6 $DEADWOOD_DIR/src/Makefile
+ fi
+
+ echo
+--
+2.26.3
+
diff --git a/net-dns/maradns/maradns-3.5.0020.ebuild b/net-dns/maradns/maradns-3.5.0020.ebuild
new file mode 100644
index 000000000000..6bf474750b66
--- /dev/null
+++ b/net-dns/maradns/maradns-3.5.0020.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit python-any-r1 systemd toolchain-funcs
+
+DESCRIPTION="A security-aware DNS server"
+HOMEPAGE="https://maradns.samiam.org"
+SRC_URI="https://maradns.samiam.org/download/${PV%.*}/${PV}/${P}.tar.xz"
+
+# The GPL-2 covers the init script, bug 426018.
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE="examples ipv6"
+
+BDEPEND="${PYTHON_DEPS}
+ dev-lang/perl"
+DEPEND="
+ acct-group/maradns
+ acct-user/duende
+ acct-user/maradns"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags-ipv6.patch
+)
+
+src_prepare() {
+ default
+ python_fix_shebang tools/bind2csv2.py
+}
+
+src_configure() {
+ tc-export CC
+ ./configure \
+ $(usex ipv6 --ipv6 "") || die "Failed to configure"
+}
+
+src_install() {
+ # Install the MaraDNS and Deadwood binaries
+ dosbin server/maradns
+ dosbin tcp/zoneserver
+ dosbin deadwood-${PV}/src/Deadwood
+ dobin tcp/{getzone,fetchzone}
+ dobin tools/{askmara,askmara-tcp,duende,bind2csv2.py,csv1tocsv2.pl}
+
+ # MaraDNS docs, manpages, misc
+ docompress -x /usr/share/doc/${PF}/maradns.gpg.key
+ dodoc {CHANGELOG,COPYING,SUPPORT,maradns.gpg.key}
+ dodoc doc/en/{QuickStart,faq.*,*.md,README}
+ dodoc -r doc/en/{text,webpage,tutorial}
+ docinto deadwood
+ dodoc deadwood-${PV}/doc/{*.txt,*.html,CHANGELOG,Deadwood-HOWTO}
+ dodoc -r deadwood-${PV}/doc/internals
+
+ # Install examples (optional)
+ if use examples ; then
+ docinto examples
+ dodoc doc/en/examples/example_*
+ fi
+
+ # Install manpages
+ doman doc/en/man/*.[1-9]
+ doman deadwood-${PV}/doc/{Deadwood,Duende}.1
+
+ # Example configurations.
+ insinto /etc/maradns
+ newins doc/en/examples/example_full_mararc mararc_full.dist
+ newins doc/en/examples/example_csv2 example_csv2.dist
+ newins deadwood-${PV}/doc/dwood3rc-all dwood3rc_all.dist
+ keepdir /etc/maradns/logger
+
+ # Init scripts.
+ newinitd "${FILESDIR}"/maradns2 maradns
+ newinitd "${FILESDIR}"/zoneserver2 zoneserver
+ newinitd "${FILESDIR}"/deadwood deadwood
+
+ # systemd unit
+ # please keep paths in sync!
+ sed -e "s^@bindir@^${EPREFIX}/usr/sbin^" \
+ -e "s^@sysconfdir@^${EPREFIX}/etc/maradns^" \
+ "${FILESDIR}"/maradns.service.in > "${T}"/maradns.service \
+ || die "failed to create the maradns.service file (sed)"
+
+ systemd_dounit "${T}"/maradns.service
+}
+
+pkg_postinst() {
+ elog "Examples of configuration files can be found in the"
+ elog "/etc/maradns directory, feel free use it like:"
+ elog " cp /etc/maradns/mararc{_full.dist,}"
+ elog "and edit /etc/maradns/mararc as described in man mararc."
+}