summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2020-10-17 11:23:09 +0200
committerSven Wegener <swegener@gentoo.org>2020-10-17 11:23:29 +0200
commitedf1122e56fa58755f0da35606bbac283bf1bd30 (patch)
tree7f47c1ab1ee2042f296d0d962f91cd3a5fc02b46 /net-dns
parentdev-python/python-editor: support PyPy3+Python3.9, remove six dep. (diff)
downloadgentoo-edf1122e56fa58755f0da35606bbac283bf1bd30.tar.gz
gentoo-edf1122e56fa58755f0da35606bbac283bf1bd30.tar.bz2
gentoo-edf1122e56fa58755f0da35606bbac283bf1bd30.zip
net-dns/pdns-recursor: Cleanup
Bug: https://bugs.gentoo.org/746923 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns-recursor/Manifest2
-rw-r--r--net-dns/pdns-recursor/files/pdns-recursor-4.3.1-boost-1.73.0.patch89
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.3.3.ebuild85
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.3.4.ebuild85
4 files changed, 0 insertions, 261 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index 6208b5c960ab..32b5c61225bb 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1,4 +1,2 @@
-DIST pdns-recursor-4.3.3.tar.bz2 1357853 BLAKE2B fa57776bbdb77d1f13f04fdd1fb5ceb07539f851704dc627443a7c814d6640b1e7890333b6d7214a201f5d3f83a54a7840adb6450ffb7696e58722625b7c57c5 SHA512 285f12d3cb2edaca7507dd9dad1356b60076d43af678458346489562ea8933a01d61d2430d5282b6afd213839ee684ad83e5f523c9a272f382d74ccc238bd9d5
-DIST pdns-recursor-4.3.4.tar.bz2 1359380 BLAKE2B b55829b843f3abc9394bcb943c223b24684ebe67854fbde8590aded09a8ef18d8b15d1e2ebe1b88d24833b8782266b1ce853d98c0ce510e115e8d16ce900ece2 SHA512 cfc34f42ed95c7fd2be1ab7ba172672e5e1db96b4ced171c1eae7bd60fb7db482aed928028811b133d326550de35c506a8fc480b12ae39ab7fa142408e0b42d8
DIST pdns-recursor-4.3.5.tar.bz2 1341930 BLAKE2B 8f81182cb5283e6b8f459c5d23281d20cba02d22cec8776fdab67d452834b82945f467186c98784519d2c79d9df8438b174fc644fb11d68d04f9f636e51a5551 SHA512 2d39e6016000951c0beca38b26c41664b57c059dee762d7499f34e599ed6c2653af73edb31ba5a8d35f749534f24c0d85b6aedf4c35dc8a05777ffebd1b25851
DIST pdns-recursor-4.4.0-rc2.tar.bz2 1393346 BLAKE2B 00f03dc05747e3b0962fdbff0e2d15b8e9d4703b84bafa086a5e1c229613b42d010ec963296845fe981c9bb99f02f8d60897fe180943091d0b904d0f65f453c0 SHA512 91f63924c30d89bf06dcaf48a588f116cedef530319b4e4682daf14682998b4879aca5d1796aa36a50ba327053523659f9a8ad180d592e5857f898e37f0064ec
diff --git a/net-dns/pdns-recursor/files/pdns-recursor-4.3.1-boost-1.73.0.patch b/net-dns/pdns-recursor/files/pdns-recursor-4.3.1-boost-1.73.0.patch
deleted file mode 100644
index 02b8df751ef9..000000000000
--- a/net-dns/pdns-recursor/files/pdns-recursor-4.3.1-boost-1.73.0.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From 71246536642590e8e8b21c11307ec4bd0e165066 Mon Sep 17 00:00:00 2001
-From: Remi Gacogne <remi.gacogne@powerdns.com>
-Date: Tue, 28 Apr 2020 17:51:47 +0200
-Subject: [PATCH] Replace boost's placeholders with the ones from the std
- namespace
-
-Boost 1.73 moved boost::bind placeholders to the placeholders
-namespace which did not exist before 1.60, let's switch to
-std::bind and std::placeholders instead of doing per-version handling.
----
- pdns/ixfrdist-web.cc | 2 +-
- pdns/webserver.cc | 6 +++---
- pdns/ws-auth.cc | 4 ++--
- pdns/ws-recursor.cc | 12 ++++++------
- 4 files changed, 12 insertions(+), 12 deletions(-)
-
-diff --git a/webserver.cc b/webserver.cc
-index eafd3059a0..b47cc6d7e0 100644
---- a/webserver.cc
-+++ b/webserver.cc
-@@ -107,7 +107,7 @@ static void bareHandlerWrapper(WebServer::HandlerFunction handler, YaHTTP::Reque
-
- void WebServer::registerBareHandler(const string& url, HandlerFunction handler)
- {
-- YaHTTP::THandlerFunction f = boost::bind(&bareHandlerWrapper, handler, _1, _2);
-+ YaHTTP::THandlerFunction f = std::bind(&bareHandlerWrapper, handler, std::placeholders::_1, std::placeholders::_2);
- YaHTTP::Router::Any(url, f);
- }
-
-@@ -179,7 +179,7 @@ void WebServer::apiWrapper(WebServer::HandlerFunction handler, HttpRequest* req,
- }
-
- void WebServer::registerApiHandler(const string& url, HandlerFunction handler, bool allowPassword) {
-- HandlerFunction f = boost::bind(&WebServer::apiWrapper, this, handler, _1, _2, allowPassword);
-+ HandlerFunction f = std::bind(&WebServer::apiWrapper, this, handler, std::placeholders::_1, std::placeholders::_2, allowPassword);
- registerBareHandler(url, f);
- }
-
-@@ -196,7 +196,7 @@ void WebServer::webWrapper(WebServer::HandlerFunction handler, HttpRequest* req,
- }
-
- void WebServer::registerWebHandler(const string& url, HandlerFunction handler) {
-- HandlerFunction f = boost::bind(&WebServer::webWrapper, this, handler, _1, _2);
-+ HandlerFunction f = std::bind(&WebServer::webWrapper, this, handler, std::placeholders::_1, std::placeholders::_2);
- registerBareHandler(url, f);
- }
-
-diff --git a/ws-recursor.cc b/ws-recursor.cc
-index cd8997309f..a074460c2f 100644
---- a/ws-recursor.cc
-+++ b/ws-recursor.cc
-@@ -382,9 +382,9 @@ static void apiServerCacheFlush(HttpRequest* req, HttpResponse* resp) {
- DNSName canon = apiNameToDNSName(req->getvars["domain"]);
- bool subtree = (req->getvars.count("subtree") > 0 && req->getvars["subtree"].compare("true") == 0);
-
-- int count = broadcastAccFunction<uint64_t>(boost::bind(pleaseWipeCache, canon, subtree));
-- count += broadcastAccFunction<uint64_t>(boost::bind(pleaseWipePacketCache, canon, subtree));
-- count += broadcastAccFunction<uint64_t>(boost::bind(pleaseWipeAndCountNegCache, canon, subtree));
-+ int count = broadcastAccFunction<uint64_t>(std::bind(pleaseWipeCache, canon, subtree));
-+ count += broadcastAccFunction<uint64_t>(std::bind(pleaseWipePacketCache, canon, subtree));
-+ count += broadcastAccFunction<uint64_t>(std::bind(pleaseWipeAndCountNegCache, canon, subtree));
- resp->setBody(Json::object {
- { "count", count },
- { "result", "Flushed cache." }
-@@ -512,7 +512,7 @@ RecursorWebServer::RecursorWebServer(FDMultiplexer* fdm)
- d_ws->bind();
-
- // legacy dispatch
-- d_ws->registerApiHandler("/jsonstat", boost::bind(&RecursorWebServer::jsonstat, this, _1, _2), true);
-+ d_ws->registerApiHandler("/jsonstat", std::bind(&RecursorWebServer::jsonstat, this, std::placeholders::_1, std::placeholders::_2), true);
- d_ws->registerApiHandler("/api/v1/servers/localhost/cache/flush", &apiServerCacheFlush);
- d_ws->registerApiHandler("/api/v1/servers/localhost/config/allow-from", &apiServerConfigAllowFrom);
- d_ws->registerApiHandler("/api/v1/servers/localhost/config", &apiServerConfig);
-@@ -664,7 +664,7 @@ void AsyncServerNewConnectionMT(void *p) {
- void AsyncServer::asyncWaitForConnections(FDMultiplexer* fdm, const newconnectioncb_t& callback)
- {
- d_asyncNewConnectionCallback = callback;
-- fdm->addReadFD(d_server_socket.getHandle(), boost::bind(&AsyncServer::newConnection, this));
-+ fdm->addReadFD(d_server_socket.getHandle(), std::bind(&AsyncServer::newConnection, this));
- }
-
- void AsyncServer::newConnection()
-@@ -743,5 +743,5 @@ void AsyncWebServer::go() {
- auto server = std::dynamic_pointer_cast<AsyncServer>(d_server);
- if (!server)
- return;
-- server->asyncWaitForConnections(d_fdm, boost::bind(&AsyncWebServer::serveConnection, this, _1));
-+ server->asyncWaitForConnections(d_fdm, std::bind(&AsyncWebServer::serveConnection, this, std::placeholders::_1));
- }
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.3.3.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.3.3.ebuild
deleted file mode 100644
index bffba0080a4c..000000000000
--- a/net-dns/pdns-recursor/pdns-recursor-4.3.3.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit flag-o-matic
-
-DESCRIPTION="The PowerDNS Recursor"
-HOMEPAGE="https://www.powerdns.com/"
-SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE="debug dnstap libressl luajit protobuf snmp sodium systemd"
-REQUIRED_USE="dnstap? ( protobuf )"
-
-DEPEND="!luajit? ( >=dev-lang/lua-5.1:= )
- luajit? ( dev-lang/luajit:= )
- protobuf? (
- dev-libs/protobuf
- >=dev-libs/boost-1.42:=
- )
- dnstap? ( dev-libs/fstrm )
- systemd? ( sys-apps/systemd:0= )
- snmp? ( net-analyzer/net-snmp )
- sodium? ( dev-libs/libsodium:= )
- libressl? ( dev-libs/libressl:= )
- !libressl? ( dev-libs/openssl:= )
- >=dev-libs/boost-1.35:="
-RDEPEND="${DEPEND}
- !<net-dns/pdns-2.9.20-r1
- acct-user/pdns
- acct-group/pdns"
-BDEPEND="virtual/pkgconfig"
-
-S="${WORKDIR}"/${P/_/-}
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.3.1-boost-1.73.0.patch
-)
-
-pkg_setup() {
- filter-flags -ftree-vectorize
-}
-
-src_configure() {
- econf \
- --sysconfdir=/etc/powerdns \
- --with-lua=$(usex luajit luajit lua) \
- $(use_enable debug verbose-logging) \
- $(use_enable systemd) \
- $(use_enable dnstap dnstap) \
- $(use_with sodium libsodium) \
- $(use_with protobuf) \
- $(use_with snmp net-snmp)
-}
-
-src_install() {
- default
-
- mv "${D}"/etc/powerdns/recursor.conf{-dist,}
-
- # set defaults: setuid=nobody, setgid=nobody
- sed -i \
- -e 's/^# set\([ug]\)id=$/set\1id=pdns/' \
- -e 's/^# quiet=$/quiet=on/' \
- -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
- "${D}"/etc/powerdns/recursor.conf
-
- newinitd "${FILESDIR}"/pdns-recursor-r2 pdns-recursor
-}
-
-pkg_postinst() {
- local old
-
- for old in ${REPLACING_VERSIONS}; do
- ver_test ${old} -lt 4.0.0-r1 || continue
-
- ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
- ewarn "to pdns-recursor, please update your runlevels accordingly."
-
- break
- done
-}
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.3.4.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.3.4.ebuild
deleted file mode 100644
index cb9a0daba0e2..000000000000
--- a/net-dns/pdns-recursor/pdns-recursor-4.3.4.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit flag-o-matic
-
-DESCRIPTION="The PowerDNS Recursor"
-HOMEPAGE="https://www.powerdns.com/"
-SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="debug dnstap libressl luajit protobuf snmp sodium systemd"
-REQUIRED_USE="dnstap? ( protobuf )"
-
-DEPEND="!luajit? ( >=dev-lang/lua-5.1:= )
- luajit? ( dev-lang/luajit:= )
- protobuf? (
- dev-libs/protobuf
- >=dev-libs/boost-1.42:=
- )
- dnstap? ( dev-libs/fstrm )
- systemd? ( sys-apps/systemd:0= )
- snmp? ( net-analyzer/net-snmp )
- sodium? ( dev-libs/libsodium:= )
- libressl? ( dev-libs/libressl:= )
- !libressl? ( dev-libs/openssl:= )
- >=dev-libs/boost-1.35:="
-RDEPEND="${DEPEND}
- !<net-dns/pdns-2.9.20-r1
- acct-user/pdns
- acct-group/pdns"
-BDEPEND="virtual/pkgconfig"
-
-S="${WORKDIR}"/${P/_/-}
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.3.1-boost-1.73.0.patch
-)
-
-pkg_setup() {
- filter-flags -ftree-vectorize
-}
-
-src_configure() {
- econf \
- --sysconfdir=/etc/powerdns \
- --with-lua=$(usex luajit luajit lua) \
- $(use_enable debug verbose-logging) \
- $(use_enable systemd) \
- $(use_enable dnstap dnstap) \
- $(use_with sodium libsodium) \
- $(use_with protobuf) \
- $(use_with snmp net-snmp)
-}
-
-src_install() {
- default
-
- mv "${D}"/etc/powerdns/recursor.conf{-dist,}
-
- # set defaults: setuid=nobody, setgid=nobody
- sed -i \
- -e 's/^# set\([ug]\)id=$/set\1id=pdns/' \
- -e 's/^# quiet=$/quiet=on/' \
- -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
- "${D}"/etc/powerdns/recursor.conf
-
- newinitd "${FILESDIR}"/pdns-recursor-r2 pdns-recursor
-}
-
-pkg_postinst() {
- local old
-
- for old in ${REPLACING_VERSIONS}; do
- ver_test ${old} -lt 4.0.0-r1 || continue
-
- ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
- ewarn "to pdns-recursor, please update your runlevels accordingly."
-
- break
- done
-}