summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2021-12-25 15:18:45 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-01-03 20:01:35 +0100
commit5b1d9775db5ad1db1cece6c55fddd5f01193410e (patch)
tree32b8e9174ace84e5aae2e331db01ef21bb8dae10 /net-ftp/uftpd/uftpd-2.15.ebuild
parentdev-python/numexpr: Stabilize 2.8.1 ppc64, #830542 (diff)
downloadgentoo-5b1d9775db5ad1db1cece6c55fddd5f01193410e.tar.gz
gentoo-5b1d9775db5ad1db1cece6c55fddd5f01193410e.tar.bz2
gentoo-5b1d9775db5ad1db1cece6c55fddd5f01193410e.zip
net-ftp/uftpd: add 2.15
Signed-off-by: Oz N Tiram <oz.tiram@gmail.com> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-ftp/uftpd/uftpd-2.15.ebuild')
-rw-r--r--net-ftp/uftpd/uftpd-2.15.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-ftp/uftpd/uftpd-2.15.ebuild b/net-ftp/uftpd/uftpd-2.15.ebuild
new file mode 100644
index 000000000000..abc498a16b38
--- /dev/null
+++ b/net-ftp/uftpd/uftpd-2.15.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The no nonsense TFTP/FTP server"
+HOMEPAGE="https://github.com/troglobit/uftpd"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libite-1.5
+ >=dev-libs/libuev-2.2"
+
+DEPEND="
+ ${RDEPEND}
+ !net-misc/uftp
+ !net-ftp/atftp
+ !net-ftp/tftp-hpa[server(+)]
+ test? (
+ net-ftp/ftp
+ net-ftp/tnftp
+ >=net-ftp/tftp-hpa-5.2-r2[client]
+ )"
+
+src_test() {
+ # can't run the tests in parallel since the order matters
+ emake -j 1 check
+}