summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/ayttm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/ayttm')
-rw-r--r--net-im/ayttm/Manifest1
-rw-r--r--net-im/ayttm/ayttm-0.6.3.ebuild67
-rw-r--r--net-im/ayttm/files/ayttm-0.6.3-opt-webcam.patch28
-rw-r--r--net-im/ayttm/files/ayttm-0.6.3-opt-xscreensaver.patch16
-rw-r--r--net-im/ayttm/metadata.xml19
5 files changed, 131 insertions, 0 deletions
diff --git a/net-im/ayttm/Manifest b/net-im/ayttm/Manifest
new file mode 100644
index 000000000000..f8e608210834
--- /dev/null
+++ b/net-im/ayttm/Manifest
@@ -0,0 +1 @@
+DIST ayttm-0.6.3.tar.bz2 1377010 SHA256 2c48d3b8183139e7657c03dab9d17c997077624fd97a177d932f80ee6c596157
diff --git a/net-im/ayttm/ayttm-0.6.3.ebuild b/net-im/ayttm/ayttm-0.6.3.ebuild
new file mode 100644
index 000000000000..079efe16e8ac
--- /dev/null
+++ b/net-im/ayttm/ayttm-0.6.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils multilib
+
+DESCRIPTION="A multi-protocol instant messaging client"
+HOMEPAGE="http://ayttm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ayttm/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt icq irc xmpp lj msn nls oscar smtp webcam xscreensaver yahoo"
+
+CDEPEND="app-text/enchant
+ dev-libs/glib:2
+ dev-libs/openssl
+ virtual/libiconv
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/pango
+ crypt? ( app-crypt/gpgme )
+ webcam? ( media-libs/jasper )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ yahoo? ( net-libs/libyahoo2 )"
+RDEPEND="${CDEPEND}
+ webcam? ( media-tv/xawtv )"
+DEPEND="${CDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-opt-xscreensaver.patch \
+ "${FILESDIR}"/${P}-opt-webcam.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable crypt aycryption) \
+ --disable-esd \
+ $(use_enable icq) \
+ $(use_enable irc) \
+ $(use_enable xmpp jabber) \
+ $(use_enable lj) \
+ $(use_enable msn) \
+ $(use_enable nls) \
+ $(use_enable oscar) \
+ $(use_enable smtp) \
+ $(use_enable webcam) \
+ $(use_enable xscreensaver) \
+ $(use_enable yahoo) \
+ --disable-arts \
+ --enable-posix-dlopen \
+ --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README README.LINUX TODO
+ rm -f "${D}"/usr/$(get_libdir)/${PN}/*.la
+}
diff --git a/net-im/ayttm/files/ayttm-0.6.3-opt-webcam.patch b/net-im/ayttm/files/ayttm-0.6.3-opt-webcam.patch
new file mode 100644
index 000000000000..e805d90746d6
--- /dev/null
+++ b/net-im/ayttm/files/ayttm-0.6.3-opt-webcam.patch
@@ -0,0 +1,28 @@
+Make the building of the webcam-related plugins optional.
+
+Patch by Kevin McCarthy <signals@gentoo.org>
+
+--- configure.ac
++++ configure.ac
+@@ -436,6 +439,10 @@
+ AC_MSG_WARN(You need gpgme to compile the aycryption module))
+ fi
+
++if test "$enable_webcam" != no; then
++ OPTIONAL_PLUG_DIR="$OPTIONAL_PLUG_DIR image_filter"
++fi
++
+ ###########################################################################
+ # End Optional Modules
+ ###########################################################################
+--- modules/Makefile.am
++++ modules/Makefile.am
+@@ -1,7 +1,7 @@
+ DIST_SUBDIRS = aim-oscar irc jabber msn2 yahoo2 smtp importers \
+ livejournal utility aycryption smileys image_filter
+
+-SUBDIRS = @OPTIONAL_PLUG_DIR@ importers utility smileys image_filter
++SUBDIRS = @OPTIONAL_PLUG_DIR@ importers utility smileys
+
+ # Gets rid of the datarootdir warning
+ datarootdir=@datarootdir@
diff --git a/net-im/ayttm/files/ayttm-0.6.3-opt-xscreensaver.patch b/net-im/ayttm/files/ayttm-0.6.3-opt-xscreensaver.patch
new file mode 100644
index 000000000000..7c6f09f5117e
--- /dev/null
+++ b/net-im/ayttm/files/ayttm-0.6.3-opt-xscreensaver.patch
@@ -0,0 +1,16 @@
+Add --enable-xscreensaver to configure for USE flag support
+
+Patch by Kevin McCarthy <signals@gentoo.org>
+
+--- configure.ac
++++ configure.ac
+@@ -316,6 +316,9 @@
+ #endif
+ ])
+
++AC_ARG_ENABLE(xscreensaver, AC_HELP_STRING([--enable-xscreensaver],
++ [compile with X Screensaver]), [have_xss=$enableval], [have_xss=no] )
++
+ if test "$have_xss" = yes; then
+ # Let's figure out what library it's in...
+
diff --git a/net-im/ayttm/metadata.xml b/net-im/ayttm/metadata.xml
new file mode 100644
index 000000000000..06a0a876dacd
--- /dev/null
+++ b/net-im/ayttm/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <longdescription lang="en">
+ Ayttm is a multi-protocol instant messaging client with some novel features
+ such as the ability to connect to livejournal.com and the ability to send
+ short messages via RFC2821 SMTP.
+ </longdescription>
+ <use>
+ <flag name="irc">Enable Internet Relay Chat support</flag>
+ <flag name="lj">Enable livejournal.com support</flag>
+ <flag name="smtp">Adds support for sending messages via RFC2821 SMTP</flag>
+ <flag name="webcam">Adds webcam support for Yahoo Messenger</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">ayttm</remote-id>
+ </upstream>
+</pkgmetadata>