summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/pidgin/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/pidgin/files')
-rw-r--r--net-im/pidgin/files/pidgin-2.10.0-gold.patch30
-rw-r--r--net-im/pidgin/files/pidgin-2.10.10-eds-3.6-configure.ac.patch23
-rw-r--r--net-im/pidgin/files/pidgin-2.10.11-tinfo.patch24
-rw-r--r--net-im/pidgin/files/pidgin-2.10.9-fix-gtkmedia.patch10
4 files changed, 87 insertions, 0 deletions
diff --git a/net-im/pidgin/files/pidgin-2.10.0-gold.patch b/net-im/pidgin/files/pidgin-2.10.0-gold.patch
new file mode 100644
index 000000000000..819bfdc5c6bf
--- /dev/null
+++ b/net-im/pidgin/files/pidgin-2.10.0-gold.patch
@@ -0,0 +1,30 @@
+ pidgin/Makefile.am | 2 +-
+ pidgin/Makefile.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/pidgin/Makefile.am b/pidgin/Makefile.am
+index b6a5bd4..96d207d 100644
+--- a/pidgin/Makefile.am
++++ b/pidgin/Makefile.am
+@@ -158,7 +158,7 @@ pidgin_LDADD = \
+ $(GTKSPELL_LIBS) \
+ $(LIBXML_LIBS) \
+ $(GTK_LIBS) \
+- $(top_builddir)/libpurple/libpurple.la
++ $(top_builddir)/libpurple/libpurple.la -lm
+
+ if USE_INTERNAL_LIBGADU
+ INTGG_CFLAGS = -DUSE_INTERNAL_LIBGADU
+diff --git a/pidgin/Makefile.in b/pidgin/Makefile.in
+index 615c196..0293e5c 100644
+--- a/pidgin/Makefile.in
++++ b/pidgin/Makefile.in
+@@ -607,7 +607,7 @@ EXTRA_DIST = \
+ @ENABLE_GTK_TRUE@ $(GTKSPELL_LIBS) \
+ @ENABLE_GTK_TRUE@ $(LIBXML_LIBS) \
+ @ENABLE_GTK_TRUE@ $(GTK_LIBS) \
+-@ENABLE_GTK_TRUE@ $(top_builddir)/libpurple/libpurple.la
++@ENABLE_GTK_TRUE@ $(top_builddir)/libpurple/libpurple.la -lm
+
+ @ENABLE_GTK_TRUE@@USE_INTERNAL_LIBGADU_TRUE@INTGG_CFLAGS = -DUSE_INTERNAL_LIBGADU
+ @ENABLE_GTK_TRUE@AM_CPPFLAGS = \
diff --git a/net-im/pidgin/files/pidgin-2.10.10-eds-3.6-configure.ac.patch b/net-im/pidgin/files/pidgin-2.10.10-eds-3.6-configure.ac.patch
new file mode 100644
index 000000000000..555ef8c1ab16
--- /dev/null
+++ b/net-im/pidgin/files/pidgin-2.10.10-eds-3.6-configure.ac.patch
@@ -0,0 +1,23 @@
+diff -urN pidgin-2.10.10.orig/configure.ac pidgin-2.10.10/configure.ac
+--- pidgin-2.10.10.orig/configure.ac 2014-10-17 04:19:33.000000000 +0400
++++ pidgin-2.10.10/configure.ac 2014-10-28 15:56:27.853702740 +0300
+@@ -569,18 +569,10 @@
+ dnl # Check for stuff needed by the Evolution integration plugin.
+ dnl #######################################################################
+ if test "x$enable_gevolution" = "xyes"; then
+- evo_deps="libebook-1.2 libedata-book-1.2 evolution-data-server-1.2 < 3.6"
++ evo_deps="libebook-1.2 libedata-book-1.2 evolution-data-server-1.2 >= 3.6"
+ PKG_CHECK_MODULES(EVOLUTION_ADDRESSBOOK, $evo_deps, , [
+ enable_gevolution="no"
+ ])
+- if test "x$enable_gevolution" = "xno"; then
+- evo_deps="libebook-1.0 libedata-book-1.0"
+- PKG_CHECK_MODULES(EVOLUTION_ADDRESSBOOK, $evo_deps, [
+- enable_gevolution="yes"
+- ], [
+- enable_gevolution="no"
+- ])
+- fi
+ if test "x$enable_gevolution" = "xyes"; then
+ AC_DEFINE(HAVE_EVOLUTION_ADDRESSBOOK, 1, [Define if we're using evolution addressbook.])
+ AC_SUBST(EVOLUTION_ADDRESSBOOK_CFLAGS)
diff --git a/net-im/pidgin/files/pidgin-2.10.11-tinfo.patch b/net-im/pidgin/files/pidgin-2.10.11-tinfo.patch
new file mode 100644
index 000000000000..370ac62a6e23
--- /dev/null
+++ b/net-im/pidgin/files/pidgin-2.10.11-tinfo.patch
@@ -0,0 +1,24 @@
+ configure.ac | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 51471b1..81c57ff 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -635,6 +635,8 @@ AC_ARG_WITH(ncurses-headers, [AC_HELP_STRING([--with-ncurses-headers=DIR],
+ [compile finch against the ncurses includes in DIR])],
+ [ac_ncurses_includes="$withval"], [ac_ncurses_includes=""])
+ if test "x$enable_consoleui" = "xyes"; then
++ PKG_CHECK_MODULES([GNT], [ncursesw panelw], [], [
++ PKG_CHECK_MODULES([GNT], [ncurses panel], [], [
+ AC_CHECK_LIB(ncursesw, initscr, [GNT_LIBS="-lncursesw"], [enable_consoleui=no])
+ AC_CHECK_LIB(panelw, update_panels, [GNT_LIBS="$GNT_LIBS -lpanelw"],
+ [enable_consoleui=no], [$GNT_LIBS])
+@@ -699,6 +701,7 @@ if test "x$enable_consoleui" = "xyes"; then
+ fi
+ fi
+ fi
++ ])])
+ fi
+
+ if test "x$force_finch" = "xyes" -a "x$enable_consoleui" != "xyes"; then
diff --git a/net-im/pidgin/files/pidgin-2.10.9-fix-gtkmedia.patch b/net-im/pidgin/files/pidgin-2.10.9-fix-gtkmedia.patch
new file mode 100644
index 000000000000..4cec32663808
--- /dev/null
+++ b/net-im/pidgin/files/pidgin-2.10.9-fix-gtkmedia.patch
@@ -0,0 +1,10 @@
+--- a/pidgin/Makefile.am 2014-02-02 22:29:20.000000000 +0100
++++ b/pidgin/Makefile.am 2014-02-14 19:35:24.347547795 +0100
+@@ -154,6 +154,7 @@
+ $(GSTREAMER_LIBS) \
+ $(XSS_LIBS) \
+ $(SM_LIBS) \
++ $(X11_LIBS) \
+ $(INTLLIBS) \
+ $(GTKSPELL_LIBS) \
+ $(LIBXML_LIBS) \