summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-27 20:52:19 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-27 20:52:19 +0100
commitf1fc957eed3154738cd106a16abb0b4c9c9bde31 (patch)
treeb15fddec95532a0dc173ef8e5207029b33d8af8d /net-im/rocketchat-desktop-bin
parentmedia-video/popcorntime-bin: add new package (diff)
downloadgentoo-f1fc957eed3154738cd106a16abb0b4c9c9bde31.tar.gz
gentoo-f1fc957eed3154738cd106a16abb0b4c9c9bde31.tar.bz2
gentoo-f1fc957eed3154738cd106a16abb0b4c9c9bde31.zip
net-im/rocketchat-desktop-bin: add version 3.7.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im/rocketchat-desktop-bin')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 21f0f9df253d..e72ebb33fcef 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.7.1.x86_64.rpm 72045700 BLAKE2B 352f7921a5cd409410dcd6744e29f70851fbb884b2f1a328288e9b787b2edacf671b0bd45052f6973541615b0e9dc942d3bce55f6e850d154708192a078c9a93 SHA512 e55aa242ce9b017d7a2c435dd5db4751a22f2fd3b56b64f6ea57c5c9c15e2f5f849b32d1f024243923a5dc49364ed0c7db0fd10f2fda9fdd992b5078c258d4b3
+DIST rocketchat-3.7.2.x86_64.rpm 72045336 BLAKE2B 7c40abf16fa9a5d45809bb142f491da35b8bd0096b66b966e4e6a63520e6b4387aed6cbfeefc9ccdd1806171cb6e71259833c3691a88c3093cb8465e74d4672c SHA512 bcf94c6b0c1fbf1ae0c2c57609865a3b849283315c0e60682926cbc49eb556d144358e3c1d3792ae5f901ed7cef992f0f868c4338b9418fc6d37d0e99168778f
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.2.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.2.ebuild
new file mode 100644
index 000000000000..46fc3d26d958
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}