summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/weechat/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/weechat/files')
-rw-r--r--net-irc/weechat/files/weechat-1.2-tinfo.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-irc/weechat/files/weechat-1.2-tinfo.patch b/net-irc/weechat/files/weechat-1.2-tinfo.patch
new file mode 100644
index 000000000000..e6ae9e0f205b
--- /dev/null
+++ b/net-irc/weechat/files/weechat-1.2-tinfo.patch
@@ -0,0 +1,32 @@
+ src/gui/curses/CMakeLists.txt | 11 +++++++++--
+ 1 file changed, 9 insertions(+), 2 deletions(-)
+
+diff --git a/src/gui/curses/CMakeLists.txt b/src/gui/curses/CMakeLists.txt
+index 284956f..492fc77 100644
+--- a/src/gui/curses/CMakeLists.txt
++++ b/src/gui/curses/CMakeLists.txt
+@@ -35,7 +35,14 @@ main.c)
+
+ set(EXECUTABLE weechat)
+
+-find_package(Ncurses)
++
++find_package(PkgConfig)
++pkg_search_module(NCURSES ncursesw ncurses)
++
++if(NOT NCURSES_FOUND)
++ find_package(Ncurses)
++endif(NCURSES_FOUND)
++
+ if(NCURSES_FOUND)
+ check_include_files(ncursesw/ncurses.h NCURSESW_HEADERS)
+ if(NCURSESW_HEADERS)
+@@ -46,7 +53,7 @@ if(NCURSES_FOUND)
+ add_definitions(-DHAVE_NCURSES_H)
+ endif()
+ endif()
+- list(APPEND EXTRA_LIBS ${NCURSES_LIBRARY})
++ list(APPEND EXTRA_LIBS ${NCURSES_LIBRARY} ${NCURSES_LIBRARIES} )
+ endif()
+
+ if(${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")