summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-30 05:43:46 +0000
committerSam James <sam@gentoo.org>2020-08-30 05:43:58 +0000
commit116fd7172d5d7d66933c32aac322218181907a00 (patch)
tree93fcf28d943cf03637f59dbce7f8ed3a339d80db /net-irc
parentnet-analyzer/sslscan: cleanup (diff)
downloadgentoo-116fd7172d5d7d66933c32aac322218181907a00.tar.gz
gentoo-116fd7172d5d7d66933c32aac322218181907a00.tar.bz2
gentoo-116fd7172d5d7d66933c32aac322218181907a00.zip
net-irc/anope: cleanup old
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/anope/Manifest1
-rw-r--r--net-irc/anope/anope-2.0.6.ebuild158
-rw-r--r--net-irc/anope/metadata.xml12
3 files changed, 0 insertions, 171 deletions
diff --git a/net-irc/anope/Manifest b/net-irc/anope/Manifest
index 38d65bf722f3..335593c6ec61 100644
--- a/net-irc/anope/Manifest
+++ b/net-irc/anope/Manifest
@@ -1,2 +1 @@
-DIST anope-2.0.6-source.tar.gz 1792912 BLAKE2B 00c70723c887821d2dda065f9fdb4c4fc79a1534217dd567c2247c3ae9d0b3c1c07a9e1e9d87bfdf5f7f9be212af5139e29710224e02e80154290dd6d4b5ee7c SHA512 c100758d6159023832bc7a4dceb7d554a9b3cd9120b033efc9a93c7ff28e76a086d0594b66b9cd2946b231421217674990f2a3ebaa8a6598c2a25e2dafd1b65b
DIST anope-2.0.7-source.tar.gz 1817484 BLAKE2B 13a4628db8cb885d4636ab1897aab322f7846740e4a3fccd02a417d84a8eb3c942aebf5e0a51f8ca1108f455b44b4e280e7386b42e03f640c9b0e68943252814 SHA512 22a9f3e0d9fe7f68304062829a19b693a3414f94c90f8da601ab98995cbff7310dc22ca40749d50d6722dfb4649817d2f4b1dbe4afa3254b28980f03a491de65
diff --git a/net-irc/anope/anope-2.0.6.ebuild b/net-irc/anope/anope-2.0.6.ebuild
deleted file mode 100644
index 1d78f2271b9f..000000000000
--- a/net-irc/anope/anope-2.0.6.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake user
-
-DESCRIPTION="Anope IRC Services"
-HOMEPAGE="https://anope.org"
-SRC_URI="https://github.com/anope/anope/releases/download/${PV}/${P}-source.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="chanstats cs-fantasy-stats cs-fantasy-top gnutls irc2sql ldap
- ldap-auth ldap-oper mysql pcre posix sql-auth sql-log sql-oper
- sqlite ssl tre"
-
-REQUIRED_USE="
- chanstats? ( mysql )
- cs-fantasy-stats? ( chanstats mysql )
- cs-fantasy-top? ( chanstats mysql )
- irc2sql? ( mysql )
- ldap-auth? ( ldap )
- ldap-oper? ( ldap )
- sql-auth? ( || ( mysql sqlite ) )
- sql-log? ( mysql )
- sql-oper? ( mysql )"
-
-BDEPEND="sys-devel/gettext"
-DEPEND="${BDEPEND}
- mysql? ( dev-db/mysql-connector-c:0= )
- ssl? ( dev-libs/openssl:0= )
- gnutls? ( net-libs/gnutls:0= dev-libs/libgcrypt:0= )
- ldap? ( net-nds/openldap )
- pcre? ( dev-libs/libpcre )
- sqlite? ( dev-db/sqlite:3 )
- tre? ( dev-libs/tre )"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/anope-2.0.6-example.conf-pid-path.patch" )
-
-S="${WORKDIR}/${P}-source"
-
-pkg_pretend() {
- local replaced_version
- for replaced_version in ${REPLACING_VERSIONS} ; do
- if ver_test ${replaced_version} -lt 1.8.7 && [[ -f ${ROOT}/opt/anope/data/nick.db ]]; then
- eerror "It looks like you have an older version of Anope installed."
- eerror "To upgrade, shut down Anope and copy your databases to"
- eerror "${ROOT}/var/lib/anope and your configuration to ${ROOT}/etc/anope"
- eerror "You can do this by:"
- eerror "# mkdir -p ${ROOT}/var/lib/anope ${ROOT}/etc/anope"
- eerror "# chown anope:anope ${ROOT}/var/lib/anope"
- eerror "# mv ${ROOT}/opt/anope/data/*.db ${ROOT}/var/lib/anope"
- eerror "# mv ${ROOT}/opt/anope/data/services.conf ${ROOT}/etc/anope"
- die "Please move your anope database files from /opt/anope/data"
- fi
- done
-}
-
-pkg_setup() {
- enewgroup anope
- enewuser anope -1 -1 -1 anope
-}
-
-src_prepare() {
- anope_use_extra() {
- local useflag=$1
- local modulefile=$2
- if use $useflag; then
- ln -s "extra/${modulefile}" "modules/" || \
- die "Failed to use ${modulefile}"
- fi
- }
-
- anope_use_extra mysql "m_mysql.cpp"
- anope_use_extra sqlite "m_sqlite.cpp"
- anope_use_extra ssl "m_ssl_openssl.cpp"
- anope_use_extra gnutls "m_ssl_gnutls.cpp"
- anope_use_extra posix "m_regex_posix.cpp"
- anope_use_extra pcre "m_regex_pcre.cpp"
- anope_use_extra tre "m_regex_tre.cpp"
- anope_use_extra ldap "m_ldap.cpp"
- anope_use_extra sql-auth "m_sql_authentication.cpp"
- anope_use_extra sql-log "m_sql_log.cpp"
- anope_use_extra sql-oper "m_sql_oper.cpp"
- anope_use_extra ldap-auth "m_ldap_authentication.cpp"
- anope_use_extra ldap-oper "m_ldap_oper.cpp"
- anope_use_extra chanstats "stats/m_chanstats.cpp"
- anope_use_extra cs-fantasy-top "stats/cs_fantasy_top.cpp"
- anope_use_extra cs-fantasy-stats "stats/cs_fantasy_stats.cpp"
- anope_use_extra irc2sql "stats/irc2sql/irc2sql.cpp"
- anope_use_extra irc2sql "stats/irc2sql/irc2sql.h"
- anope_use_extra irc2sql "stats/irc2sql/tables.cpp"
- anope_use_extra irc2sql "stats/irc2sql/utils.cpp"
-
- # Avoid a silly sandbox error - tries to delete /usr/lib/modules
- sed -i '/install.*REMOVE_RECURSE.*/d' CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBIN_DIR="libexec/anope"
- -DDB_DIR="../var/lib/anope"
- -DDOC_DIR="share/doc/${PF}"
- -DLIB_DIR="$(get_libdir)/anope"
- -DLOCALE_DIR="share/locale"
- -DCONF_DIR="/etc/anope"
- -DLOGS_DIR="../var/log/anope/"
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- newinitd "${FILESDIR}/anope-init.d" "${PN}"
- cp "${FILESDIR}/anope-conf.d-v2" "${T}" || die
- sed -i "s~%LIBDIR%~${EPREFIX}/usr/$(get_libdir)/anope/~" \
- "${T}/anope-conf.d-v2" || die
- newconfd "${T}/anope-conf.d-v2" "${PN}"
- dosym ../libexec/anope/services /usr/bin/services
- dosym ../libexec/anope/anopesmtp /usr/bin/anopesmtp
- keepdir /var/log/anope /var/lib/anope/backups
- fowners anope:anope /var/{lib,log}/anope /var/lib/anope/backups
- dodoc -r docs/* data/example.conf
- insinto /etc/anope
- newins data/example.conf services.conf
- fowners -R anope:anope /etc/anope
- fperms -R 0700 /etc/anope
- fperms 0755 /var/log/anope
- fperms -R 0750 /var/lib/anope
-}
-
-pkg_preinst() {
- if [[ -n ${REPLACING_VERSIONS} ]] ; then
- local directory
- directory="${ROOT}"/var/lib/anope/pre-update
- elog "Making a backup of your databases to ${directory}"
- if [ ! -d "${directory}" ]; then
- mkdir -p "${directory}" || die "failed to create backup directory"
- chown anope:anope "${directory}"/../ || die "failed to chown data directory"
- fi
- # don't die otherwise merge will fail if there are no existing databases
- cp "${ROOT}"/var/lib/anope/*.db "${directory}"
- fi
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- elog
- ewarn "Anope won't run out of the box, you still have to configure it to match your IRCD's configuration."
- ewarn "Edit /etc/anope/services.conf to configure Anope."
- elog
- fi
-}
diff --git a/net-irc/anope/metadata.xml b/net-irc/anope/metadata.xml
index 9826ad83c454..01ccc819ffe1 100644
--- a/net-irc/anope/metadata.xml
+++ b/net-irc/anope/metadata.xml
@@ -19,17 +19,5 @@
<flag name="ssl">Provide SSL services using OpenSSL</flag>
<flag name="sql">Build modules which require SQL</flag>
<flag name="tre">Use <pkg>dev-libs/tre</pkg> for regular expressions</flag>
-
- <!-- pre 2.0.7 USE flags; deprecated -->
- <flag name="chanstats">Channel Statistics</flag>
- <flag name="cs-fantasy-stats">Enables the STATS and GSTATS commands</flag>
- <flag name="cs-fantasy-top">Enables the (G)TOP and (G)TOP10 commands</flag>
- <flag name="irc2sql">Stores channel statistics in a mysql database</flag>
- <flag name="ldap-auth">Authorize through LDAP</flag>
- <flag name="ldap-oper">Dynamically ties users to Anope opertypes via LDAP</flag>
- <flag name="posix">Add support for POSIX Compatible Regular Expressions</flag>
- <flag name="sql-auth">Authorize through SQL</flag>
- <flag name="sql-log">Additional log target in SQL</flag>
- <flag name="sql-oper">Allows granting users services operator privileges from SQL</flag>
</use>
</pkgmetadata>