summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-07-25 12:24:56 +0200
committerMarek Szuba <marecki@gentoo.org>2020-07-25 18:51:12 +0200
commit447d64844e411347a5c6e80c8879a1cc6246cfb5 (patch)
treebca6f9332d7329aaa871fefbc1037ee14aede4fd /net-libs/biblesync/biblesync-2.1.0.ebuild
parentmedia-tv/mythtv: remove old ebuild, metadata, and patch files (diff)
downloadgentoo-447d64844e411347a5c6e80c8879a1cc6246cfb5.tar.gz
gentoo-447d64844e411347a5c6e80c8879a1cc6246cfb5.tar.bz2
gentoo-447d64844e411347a5c6e80c8879a1cc6246cfb5.zip
net-libs/biblesync: bump to 2.1.0
With some tweaks by marecki. Closes: https://github.com/gentoo/gentoo/pull/16812 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/biblesync/biblesync-2.1.0.ebuild')
-rw-r--r--net-libs/biblesync/biblesync-2.1.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-libs/biblesync/biblesync-2.1.0.ebuild b/net-libs/biblesync/biblesync-2.1.0.ebuild
new file mode 100644
index 000000000000..b77fac3247e4
--- /dev/null
+++ b/net-libs/biblesync/biblesync-2.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A multicast protocol to support Bible software shared co-navigation"
+HOMEPAGE="https://wiki.crosswire.org/BibleSync"
+SRC_URI="https://github.com/karlkleinpaste/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static)
+ # To prevent multilib-strict violations
+ -DLIBDIR="${EPREFIX}"/usr/$(get_libdir)
+ )
+ cmake_src_configure
+}