summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-11 15:45:51 -0400
committerSam James <sam@gentoo.org>2024-03-11 21:31:41 +0000
commit9b4e4b96aee3ecaf845897c0206902a62881a781 (patch)
tree7c2132889af06ee3e691a8fdbe31840a2d2838f4 /net-libs/gnome-online-accounts
parentdev-libs/libpwquality: make sure elibtoolize is applied (diff)
downloadgentoo-9b4e4b96aee3ecaf845897c0206902a62881a781.tar.gz
gentoo-9b4e4b96aee3ecaf845897c0206902a62881a781.tar.bz2
gentoo-9b4e4b96aee3ecaf845897c0206902a62881a781.zip
net-libs/gnome-online-accounts: backport patch for libxml2 2.12 compat
Closes: https://bugs.gentoo.org/923628 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/gnome-online-accounts')
-rw-r--r--net-libs/gnome-online-accounts/files/b9638e2418408be4906752297e700506766dcf20.patch25
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.48.0.ebuild7
2 files changed, 31 insertions, 1 deletions
diff --git a/net-libs/gnome-online-accounts/files/b9638e2418408be4906752297e700506766dcf20.patch b/net-libs/gnome-online-accounts/files/b9638e2418408be4906752297e700506766dcf20.patch
new file mode 100644
index 000000000000..233e96966f84
--- /dev/null
+++ b/net-libs/gnome-online-accounts/files/b9638e2418408be4906752297e700506766dcf20.patch
@@ -0,0 +1,25 @@
+From b9638e2418408be4906752297e700506766dcf20 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?J=C3=BCrg=20Billeter?= <j@bitron.ch>
+Date: Fri, 24 Nov 2023 16:19:47 +0100
+Subject: [PATCH] goabackend: Fix build with libxml2 2.12
+
+libxml/xmlIO.h no longer includes libxml/parser.h.
+---
+ src/goabackend/goaewsclient.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/goabackend/goaewsclient.c b/src/goabackend/goaewsclient.c
+index 4cb23581..01a52d14 100644
+--- a/src/goabackend/goaewsclient.c
++++ b/src/goabackend/goaewsclient.c
+@@ -27,6 +27,7 @@
+ #include <glib/gi18n-lib.h>
+
+ #include <libsoup/soup.h>
++#include <libxml/parser.h>
+ #include <libxml/xmlIO.h>
+
+ #include "goaewsclient.h"
+--
+GitLab
+
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.48.0.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.48.0.ebuild
index 0fb916ac96ee..f5fe62b36550 100644
--- a/net-libs/gnome-online-accounts/gnome-online-accounts-3.48.0.ebuild
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.48.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -50,6 +50,11 @@ DEPEND="${RDEPEND}
"
BDEPEND="gtk-doc? ( dev-util/gtk-doc )"
+PATCHES=(
+ # Backport fix for libxml2 2.12
+ "${FILESDIR}"/b9638e2418408be4906752297e700506766dcf20.patch
+)
+
src_prepare() {
default
use vala && vala_setup