summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-09 09:59:21 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-09 09:59:21 +0200
commita81f1ccd703b7a39f74263cbb5b3d2fe454a4bc7 (patch)
tree80be8780e5214ab3c15d5952e1dd3a70608318ef /net-libs/http-parser
parentnet-libs/axtls: drop multilib, static-libs (diff)
downloadgentoo-a81f1ccd703b7a39f74263cbb5b3d2fe454a4bc7.tar.gz
gentoo-a81f1ccd703b7a39f74263cbb5b3d2fe454a4bc7.tar.bz2
gentoo-a81f1ccd703b7a39f74263cbb5b3d2fe454a4bc7.zip
net-libs/http-parser: drop multilib
No multilib reverse dependencies. Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs/http-parser')
-rw-r--r--net-libs/http-parser/http-parser-2.9.4-r2.ebuild (renamed from net-libs/http-parser/http-parser-2.9.4-r1.ebuild)19
1 files changed, 10 insertions, 9 deletions
diff --git a/net-libs/http-parser/http-parser-2.9.4-r1.ebuild b/net-libs/http-parser/http-parser-2.9.4-r2.ebuild
index 8ceeb33fae6e..34954b2e531a 100644
--- a/net-libs/http-parser/http-parser-2.9.4-r1.ebuild
+++ b/net-libs/http-parser/http-parser-2.9.4-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit toolchain-funcs multilib-minimal
+EAPI=8
+
+inherit toolchain-funcs
DESCRIPTION="HTTP request/response parser for C"
HOMEPAGE="https://github.com/nodejs/http-parser"
@@ -18,20 +19,20 @@ PATCHES=(
"${FILESDIR}"/${P}-non-x86-test.patch
)
-src_prepare() {
- default
+src_configure() {
tc-export CC AR
- multilib_copy_sources
}
-multilib_src_compile() {
+src_compile() {
emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" CFLAGS_FAST="${CFLAGS}" library
}
-multilib_src_test() {
+src_test() {
emake CFLAGS_DEBUG="${CFLAGS}" CFLAGS_FAST="${CFLAGS}" test
}
-multilib_src_install() {
+src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+
+ einstalldocs
}