summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-03-26 11:53:04 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-26 11:53:04 +0100
commitd4c0dc41af4744fd6ffd3f44d9e2e0cb74ef3e09 (patch)
tree62f22debd5599f11b803ec90a8fd5a591d157f28 /net-libs/libnetconf2
parentsci-geosciences/routino: Remove old (diff)
downloadgentoo-d4c0dc41af4744fd6ffd3f44d9e2e0cb74ef3e09.tar.gz
gentoo-d4c0dc41af4744fd6ffd3f44d9e2e0cb74ef3e09.tar.bz2
gentoo-d4c0dc41af4744fd6ffd3f44d9e2e0cb74ef3e09.zip
net-libs/libnetconf2: C library for building NETCONF servers and clients
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs/libnetconf2')
-rw-r--r--net-libs/libnetconf2/Manifest1
-rw-r--r--net-libs/libnetconf2/libnetconf2-1.1.36.ebuild46
-rw-r--r--net-libs/libnetconf2/metadata.xml15
3 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/libnetconf2/Manifest b/net-libs/libnetconf2/Manifest
new file mode 100644
index 000000000000..d3a88b227efa
--- /dev/null
+++ b/net-libs/libnetconf2/Manifest
@@ -0,0 +1 @@
+DIST libnetconf2-1.1.36.tar.gz 294950 BLAKE2B 20eca2ba26353dff8636c48c06fe2dfc79603234c2def66a12dc7946050a81fb8d2a7c082aa6b6b3b1632eecba84e129739e659fd76a8c30bc500526e3ef48da SHA512 6a992a8d6e933661ba8f4de56f951e2fcdc1c8807d220528866afbdf0a5b6bafb6a99d78eb5cd8a7970519687a6121cb49517946a2beae5e496b80c2d95a34b2
diff --git a/net-libs/libnetconf2/libnetconf2-1.1.36.ebuild b/net-libs/libnetconf2/libnetconf2-1.1.36.ebuild
new file mode 100644
index 000000000000..b56ba4d23efb
--- /dev/null
+++ b/net-libs/libnetconf2/libnetconf2-1.1.36.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C library for building NETCONF servers and clients"
+HOMEPAGE="https://github.com/CESNET/libnetconf2"
+SRC_URI="https://github.com/CESNET/libnetconf2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ net-libs/libyang:=
+ net-libs/libssh:0=[server]"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && dodoc -r doc/.
+}
diff --git a/net-libs/libnetconf2/metadata.xml b/net-libs/libnetconf2/metadata.xml
new file mode 100644
index 000000000000..4856bf68220b
--- /dev/null
+++ b/net-libs/libnetconf2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jakov.smolic@sartura.hr</email>
+ <name>Jakov Smolic</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">CESNET/libnetconf2</remote-id>
+ </upstream>
+</pkgmetadata>