summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-04 05:29:09 +0000
committerSam James <sam@gentoo.org>2021-03-04 05:29:09 +0000
commit3710296030a5439c1034dba302d249ad0736e7bb (patch)
tree966021ceabe1d75492b68329e68e4be251f1b526 /net-libs/libpcap
parentgames-strategy/0ad: Keyword 0.0.24b_alpha arm64, #773634 (diff)
downloadgentoo-3710296030a5439c1034dba302d249ad0736e7bb.tar.gz
gentoo-3710296030a5439c1034dba302d249ad0736e7bb.tar.bz2
gentoo-3710296030a5439c1034dba302d249ad0736e7bb.zip
Revert "dev-libs/hiredis: remove 0.14.1"
This reverts commit 3cb8d20c8f4e3d211e1acfc05cb7fc3ea4dc3a2d. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libpcap')
-rw-r--r--net-libs/libpcap/files/libpcap-1.8.1-usbmon.patch16
-rw-r--r--net-libs/libpcap/libpcap-1.9.1-r3.ebuild84
2 files changed, 100 insertions, 0 deletions
diff --git a/net-libs/libpcap/files/libpcap-1.8.1-usbmon.patch b/net-libs/libpcap/files/libpcap-1.8.1-usbmon.patch
new file mode 100644
index 000000000000..0b69e43a3f7d
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.8.1-usbmon.patch
@@ -0,0 +1,16 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1493,10 +1493,9 @@
+ AC_DEFINE(PCAP_SUPPORT_USB, 1, [target host supports USB sniffing])
+ USB_SRC=pcap-usb-linux.c
+ AC_MSG_RESULT(yes)
+- ac_usb_dev_name=`udevinfo -q name -p /sys/class/usb_device/usbmon 2>/dev/null`
+- if test $? -ne 0 ; then
+- ac_usb_dev_name="usbmon"
+- fi
++
++ ac_usb_dev_name="usbmon"
++
+ AC_DEFINE_UNQUOTED(LINUX_USB_MON_DEV, "/dev/$ac_usb_dev_name", [path for device for USB sniffing])
+ AC_MSG_NOTICE(Device for USB sniffing is /dev/$ac_usb_dev_name)
+ #
diff --git a/net-libs/libpcap/libpcap-1.9.1-r3.ebuild b/net-libs/libpcap/libpcap-1.9.1-r3.ebuild
new file mode 100644
index 000000000000..5e862ad5bd47
--- /dev/null
+++ b/net-libs/libpcap/libpcap-1.9.1-r3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools multilib-minimal
+
+DESCRIPTION="A system-independent library for user-level network packet capture"
+HOMEPAGE="
+ https://www.tcpdump.org/
+ https://github.com/the-tcpdump-group/libpcap
+"
+SRC_URI="
+ https://github.com/the-tcpdump-group/${PN}/archive/${P/_}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE="bluetooth dbus netlink rdma -remote static-libs usb -yydebug"
+
+RDEPEND="
+ bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ netlink? ( dev-libs/libnl:3[${MULTILIB_USEDEP}] )
+ rdma? ( sys-cluster/rdma-core )
+ usb? ( virtual/libusb:1[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc
+ dbus? ( virtual/pkgconfig )
+"
+
+S=${WORKDIR}/${PN}-${P/_}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.1-usbmon.patch
+ "${FILESDIR}"/${PN}-1.9.1-pcap-config.patch
+)
+
+src_prepare() {
+ default
+
+ echo ${PV} > VERSION || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable bluetooth) \
+ $(use_enable dbus) \
+ $(use_enable rdma) \
+ $(use_enable remote) \
+ $(use_enable usb) \
+ $(use_enable yydebug) \
+ $(use_with netlink libnl) \
+ --enable-ipv6
+}
+
+multilib_src_compile() {
+ emake all shared
+}
+
+multilib_src_install_all() {
+ dodoc CREDITS CHANGES VERSION TODO README.* doc/README.*
+
+ # remove static libraries (--disable-static does not work)
+ if ! use static-libs; then
+ find "${ED}" -name '*.a' -exec rm {} + || die
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+
+ # We need this to build pppd on G/FBSD systems
+ if [[ "${USERLAND}" == "BSD" ]]; then
+ insinto /usr/include
+ doins pcap-int.h portability.h
+ fi
+}