summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-01-15 12:28:04 -0500
committerZero_Chaos <zerochaos@gentoo.org>2018-01-15 12:31:31 -0500
commit5a6e3bf4e5f96760c494f80123af516ea68f268f (patch)
tree17499dedd2d2d5cd270255c731157c88ea6c819e /net-libs/libpcap
parentsys-kernel/gentoo-sources: Added fix e1000e ICH8 network interfaces (diff)
downloadgentoo-5a6e3bf4e5f96760c494f80123af516ea68f268f.tar.gz
gentoo-5a6e3bf4e5f96760c494f80123af516ea68f268f.tar.bz2
gentoo-5a6e3bf4e5f96760c494f80123af516ea68f268f.zip
net-libs/libpcap: import fix from debian for bug#602098
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-libs/libpcap')
-rw-r--r--net-libs/libpcap/files/libpcap-1.8.1-disable-remote.patch31
-rw-r--r--net-libs/libpcap/libpcap-1.8.1-r2.ebuild82
2 files changed, 113 insertions, 0 deletions
diff --git a/net-libs/libpcap/files/libpcap-1.8.1-disable-remote.patch b/net-libs/libpcap/files/libpcap-1.8.1-disable-remote.patch
new file mode 100644
index 000000000000..df68a5f0aa03
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.8.1-disable-remote.patch
@@ -0,0 +1,31 @@
+This patch was taken directly from debian: https://packages.debian.org/source/stretch/libpcap
+
+Disable bits of remote capture support inherited from the WinPCAP merge
+which cause applications to FTBFS if they define HAVE_REMOTE (#843384).
+
+--- a/pcap/pcap.h
++++ b/pcap/pcap.h
+@@ -506,6 +506,11 @@
+ #define MODE_STAT 1
+ #define MODE_MON 2
+
++#ifdef HAVE_REMOTE
++ /* Includes most of the public stuff that is needed for the remote capture */
++ #include <remote-ext.h>
++#endif /* HAVE_REMOTE */
++
+ #elif defined(MSDOS)
+
+ /*
+@@ -526,11 +531,6 @@
+
+ #endif /* _WIN32/MSDOS/UN*X */
+
+-#ifdef HAVE_REMOTE
+- /* Includes most of the public stuff that is needed for the remote capture */
+- #include <remote-ext.h>
+-#endif /* HAVE_REMOTE */
+-
+ #ifdef __cplusplus
+ }
+ #endif
diff --git a/net-libs/libpcap/libpcap-1.8.1-r2.ebuild b/net-libs/libpcap/libpcap-1.8.1-r2.ebuild
new file mode 100644
index 000000000000..a8f06895f6d2
--- /dev/null
+++ b/net-libs/libpcap/libpcap-1.8.1-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="A system-independent library for user-level network packet capture"
+HOMEPAGE="
+ http://www.tcpdump.org/
+ https://github.com/the-tcpdump-group/libpcap
+"
+SRC_URI="
+ https://github.com/the-tcpdump-group/${PN}/archive/${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="bluetooth dbus netlink static-libs usb"
+
+RDEPEND="
+ bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ netlink? ( dev-libs/libnl:3[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+ dbus? ( virtual/pkgconfig[${MULTILIB_USEDEP}] )
+"
+
+S=${WORKDIR}/${PN}-${P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-prefix-solaris.patch
+ "${FILESDIR}"/${PN}-1.8.1-cross-compile.patch
+ "${FILESDIR}"/${PN}-1.8.1-darwin.patch
+ "${FILESDIR}"/${PN}-1.8.1-libnl.patch
+ "${FILESDIR}"/${PN}-1.8.1-usbmon.patch
+ "${FILESDIR}"/${PN}-1.8.1-disable-remote.patch
+)
+
+src_prepare() {
+ default
+
+ eapply_user
+
+ echo ${PV} > VERSION || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable bluetooth) \
+ $(use_enable usb) \
+ $(use_enable dbus) \
+ $(use_with netlink libnl) \
+ --enable-ipv6
+}
+
+multilib_src_compile() {
+ emake all shared
+}
+
+multilib_src_install_all() {
+ dodoc CREDITS CHANGES VERSION TODO README{,.dag,.linux,.macosx,.septel}
+
+ # remove static libraries (--disable-static does not work)
+ if ! use static-libs; then
+ find "${ED}" -name '*.a' -exec rm {} + || die
+ fi
+ prune_libtool_files
+
+ # We need this to build pppd on G/FBSD systems
+ if [[ "${USERLAND}" == "BSD" ]]; then
+ insinto /usr/include
+ doins pcap-int.h portability.h
+ fi
+}