summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-04-05 11:25:58 -0400
committerCraig Andrews <candrews@gentoo.org>2024-04-05 11:26:29 -0400
commit6a7e149e6d77f55f533d008915838cdbab8ea459 (patch)
treed8f7dc0122b51e83c8cf3370058fa1c319d7b20c /net-libs/nghttp3
parentnet-libs/nghttp3: remove unused cunit dependency (diff)
downloadgentoo-6a7e149e6d77f55f533d008915838cdbab8ea459.tar.gz
gentoo-6a7e149e6d77f55f533d008915838cdbab8ea459.tar.bz2
gentoo-6a7e149e6d77f55f533d008915838cdbab8ea459.zip
net-libs/nghttp3: drop 1.1.0, 1.2.0, 1.2.0-r1
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/Manifest1
-rw-r--r--net-libs/nghttp3/nghttp3-1.1.0.ebuild40
-rw-r--r--net-libs/nghttp3/nghttp3-1.2.0-r1.ebuild39
-rw-r--r--net-libs/nghttp3/nghttp3-1.2.0.ebuild40
4 files changed, 0 insertions, 120 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index f328e6aa2949..de40c8a844fc 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1,2 +1 @@
-DIST nghttp3-1.1.0.tar.xz 369832 BLAKE2B d6b5ddf7d5809159f4f4d4f8b1750009d05d686bdfdaa882d242cf729f6cc7a950d6095aa0ab22b18d2d9dd7132d0f493bacc635617b5c74f993052bcbb964ce SHA512 30330a8002a296be4441f88f444436baba5e989b8c07dc95c55b43c85de8c2f995b000e88c6d44dc98449c10d9648dd45f641b8b24c0577c3b93e90faeba78b4
DIST nghttp3-1.2.0.tar.xz 387592 BLAKE2B b3ad897fda5d616a93f063bafde760eda6f597c90de6c81793abef3ff30de05bb2a06388fa868f95c0871a6592331d17a2d344c63817179ad21c6390bc0e499b SHA512 51ade6b17215eb15c92b18ad7a94b70e0a442d5968aee31ec734e5826d09ca34197e64407a1ac3f7bfb4ed1a0b3c3b58afc4a152542bacdcc4c71140931a7652
diff --git a/net-libs/nghttp3/nghttp3-1.1.0.ebuild b/net-libs/nghttp3/nghttp3-1.1.0.ebuild
deleted file mode 100644
index 7f4078fba594..000000000000
--- a/net-libs/nghttp3/nghttp3-1.1.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~hppa"
-fi
-
-DESCRIPTION="HTTP/3 library written in C"
-HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
-
-LICENSE="MIT"
-SLOT="0/0"
-IUSE="static-libs test"
-
-BDEPEND="virtual/pkgconfig"
-DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-RDEPEND=""
-RESTRICT="!test? ( test )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DENABLE_LIB_ONLY=ON
- -DENABLE_STATIC_LIB=$(usex static-libs)
- -DENABLE_EXAMPLES=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
- )
- cmake_src_configure
-}
-
-multilib_src_test() {
- cmake_build check
-}
diff --git a/net-libs/nghttp3/nghttp3-1.2.0-r1.ebuild b/net-libs/nghttp3/nghttp3-1.2.0-r1.ebuild
deleted file mode 100644
index 3a8480492ead..000000000000
--- a/net-libs/nghttp3/nghttp3-1.2.0-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~hppa"
-fi
-
-DESCRIPTION="HTTP/3 library written in C"
-HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
-
-LICENSE="MIT"
-SLOT="0/0"
-IUSE="static-libs test"
-
-BDEPEND="virtual/pkgconfig"
-DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-RDEPEND=""
-RESTRICT="!test? ( test )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DENABLE_LIB_ONLY=ON
- -DENABLE_STATIC_LIB=$(usex static-libs)
- -DENABLE_EXAMPLES=OFF
- )
- cmake_src_configure
-}
-
-multilib_src_test() {
- cmake_build check
-}
diff --git a/net-libs/nghttp3/nghttp3-1.2.0.ebuild b/net-libs/nghttp3/nghttp3-1.2.0.ebuild
deleted file mode 100644
index c93630cc9fef..000000000000
--- a/net-libs/nghttp3/nghttp3-1.2.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~hppa"
-fi
-
-DESCRIPTION="HTTP/3 library written in C"
-HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
-
-LICENSE="MIT"
-SLOT="0/0"
-IUSE="static-libs test"
-
-BDEPEND="virtual/pkgconfig"
-DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-RDEPEND=""
-RESTRICT="!test? ( test )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DENABLE_LIB_ONLY=ON
- -DENABLE_STATIC_LIB=$(usex static-libs)
- -DENABLE_EXAMPLES=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
- )
- cmake_src_configure
-}
-
-multilib_src_test() {
- cmake_build check
-}