summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-02-18 21:36:47 -0500
committerCraig Andrews <candrews@gentoo.org>2023-02-18 21:40:29 -0500
commit8ff9c4a8b08f3a60abc53ca3b24d0408713a425e (patch)
tree36c8e79575be8080b0d107580ad44c8a2670e6f2 /net-libs/nghttp3
parentdev-util/rizin: add a workaround for portage display issue (diff)
downloadgentoo-8ff9c4a8b08f3a60abc53ca3b24d0408713a425e.tar.gz
gentoo-8ff9c4a8b08f3a60abc53ca3b24d0408713a425e.tar.bz2
gentoo-8ff9c4a8b08f3a60abc53ca3b24d0408713a425e.zip
net-libs/nghttp3: add 0.8.0, EAPI=88888888
Closes: https://bugs.gentoo.org/895280 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/Manifest1
-rw-r--r--net-libs/nghttp3/nghttp3-0.8.0.ebuild39
-rw-r--r--net-libs/nghttp3/nghttp3-9999.ebuild4
3 files changed, 42 insertions, 2 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index 6280de1439df..00ab146d630c 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1 +1,2 @@
+DIST nghttp3-0.8.0.tar.xz 365072 BLAKE2B 132332f785f015a5e62e751ad6fe6d1dae49911837ef26cb24453245ca2cd5a80c92092db4b712f1fb515caa900ac190c2fa586fbf7314df9e60928595791679 SHA512 dab545aff7f85ee10c0f43985cb7f937e33a793c4bb0ca8e7878652f8d0b2500497cdd435256f401bf35a0c7af21aec08cd821beddff3e96b4810efb4c798591
DIST nghttp3-0_pre20190912.tar.gz 155172 BLAKE2B fabd472e429222502288b7a4030b4aa51f8a1b609590d63b51ab3f918b8cdb462b766a40911986b3f72f2f1b0debee1f0ebdf8802991bf4fc5d4a6d14297bdcc SHA512 89c7b40843bde9d2c2ab24211794b6ae0e1fa15413e92dcf2238b876552f29bb2f0db724d9a205c2a1c98f25a14ef570c9e53df52fb519230b6f78dcc04d2117
diff --git a/net-libs/nghttp3/nghttp3-0.8.0.ebuild b/net-libs/nghttp3/nghttp3-0.8.0.ebuild
new file mode 100644
index 000000000000..3685e3ee33ca
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~hppa"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_EXAMPLES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}
diff --git a/net-libs/nghttp3/nghttp3-9999.ebuild b/net-libs/nghttp3/nghttp3-9999.ebuild
index c6ed60a92ab9..3685e3ee33ca 100644
--- a/net-libs/nghttp3/nghttp3-9999.ebuild
+++ b/net-libs/nghttp3/nghttp3-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake-multilib