summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-09-13 11:53:06 -0400
committerCraig Andrews <candrews@gentoo.org>2019-09-13 16:38:05 -0400
commit0672cd383b8c56f782656d6631e2c2ba81f85372 (patch)
treeab0527e28531db4042c457cebb4f10912f4dc0fa /net-libs/ngtcp2
parentnet-misc/curl: conditionally enable alt-svc support (diff)
downloadgentoo-0672cd383b8c56f782656d6631e2c2ba81f85372.tar.gz
gentoo-0672cd383b8c56f782656d6631e2c2ba81f85372.tar.bz2
gentoo-0672cd383b8c56f782656d6631e2c2ba81f85372.zip
net-libs/ngtcp2: Implementation of the IETF QUIC Protocol
Closes: https://bugs.gentoo.org/694306 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs/ngtcp2')
-rw-r--r--net-libs/ngtcp2/Manifest1
-rw-r--r--net-libs/ngtcp2/metadata.xml11
-rw-r--r--net-libs/ngtcp2/ngtcp2-0_pre20190912.ebuild42
-rw-r--r--net-libs/ngtcp2/ngtcp2-9999.ebuild40
4 files changed, 94 insertions, 0 deletions
diff --git a/net-libs/ngtcp2/Manifest b/net-libs/ngtcp2/Manifest
new file mode 100644
index 000000000000..736d30a78734
--- /dev/null
+++ b/net-libs/ngtcp2/Manifest
@@ -0,0 +1 @@
+DIST ngtcp2-0_pre20190912.tar.gz 302984 BLAKE2B 906b248b0c19395288ed2c5ad55c8d42a9df9d76458104785c1013b9ebfaf1b92a4b87ced8755377fcb627018cf8854be0e4687e4c8a23ae994e5a21f466f739 SHA512 91b93575143960af421e8bd37d686602905fa3093750cfbbe3af1b20d743318281d22162676dc451562768ca08b6d0767b1dc28f3f8f6733235ebd76015a05bb
diff --git a/net-libs/ngtcp2/metadata.xml b/net-libs/ngtcp2/metadata.xml
new file mode 100644
index 000000000000..d47d5faabf8e
--- /dev/null
+++ b/net-libs/ngtcp2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@integralblue.com</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ngtcp2/ngtcp2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-libs/ngtcp2/ngtcp2-0_pre20190912.ebuild b/net-libs/ngtcp2/ngtcp2-0_pre20190912.ebuild
new file mode 100644
index 000000000000..a66018291013
--- /dev/null
+++ b/net-libs/ngtcp2/ngtcp2-0_pre20190912.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/ngtcp2.git"
+ inherit autotools git-r3
+else
+ GIT_COMMIT="5122d9e5e1e91c718ebc3933252ee42522c6e942"
+ SRC_URI="https://github.com/ngtcp2/ngtcp2/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${GIT_COMMIT}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Implementation of the IETF QUIC Protocol"
+HOMEPAGE="https://github.com/ngtcp2/ngtcp2/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="ssl test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="ssl? ( >=dev-libs/openssl-1.1.1:0= )
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_OpenSSL=$(usex !ssl)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libev=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_test() {
+ cmake-utils_src_make check
+}
diff --git a/net-libs/ngtcp2/ngtcp2-9999.ebuild b/net-libs/ngtcp2/ngtcp2-9999.ebuild
new file mode 100644
index 000000000000..32d61da3932e
--- /dev/null
+++ b/net-libs/ngtcp2/ngtcp2-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/ngtcp2.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/ngtcp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Implementation of the IETF QUIC Protocol"
+HOMEPAGE="https://github.com/ngtcp2/ngtcp2/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="ssl test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="ssl? ( >=dev-libs/openssl-1.1.1:0= )
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_OpenSSL=$(usex !ssl)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libev=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_test() {
+ cmake-utils_src_make check
+}