summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 20:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 19:42:20 +0100
commitbe0ab352405aa2d5d968a8c3905557b914df9626 (patch)
tree5b5da6a6ab8feb0c82b1f5c6b02e9fafdee83463 /net-libs/qxmpp
parentsys-kernel/gentoo-sources: Linux patch 5.4.7 (diff)
downloadgentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.gz
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.bz2
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.zip
*/*: Switch proxy-maint to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/qxmpp')
-rw-r--r--net-libs/qxmpp/qxmpp-1.0.1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-libs/qxmpp/qxmpp-1.0.1.ebuild b/net-libs/qxmpp/qxmpp-1.0.1.ebuild
index 3085ee7a3745..e56ca1cc2f44 100644
--- a/net-libs/qxmpp/qxmpp-1.0.1.ebuild
+++ b/net-libs/qxmpp/qxmpp-1.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="A cross-platform C++ XMPP client library based on the Qt framework"
HOMEPAGE="https://github.com/qxmpp-project/qxmpp/"
@@ -40,7 +40,7 @@ src_prepare() {
sed -e "/qxmpptransfermanager/d" \
-i tests/CMakeLists.txt || die "failed to drop single test"
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -54,5 +54,5 @@ src_configure() {
-DWITH_VPX=$(usex vpx)
)
- cmake-utils_src_configure
+ cmake_src_configure
}