summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-08-31 14:58:04 +0200
committerJeroen Roovers <jer@gentoo.org>2016-08-31 15:01:44 +0200
commit65af95dc8450cf07c64e2b5f9de34089d0295c32 (patch)
treec116bfeb2d1f6f6c01b892b8103a7df21d36fef3 /net-libs/wandio/wandio-1.0.3.ebuild
parentnet-analyzer/icinga2: bup (diff)
downloadgentoo-65af95dc8450cf07c64e2b5f9de34089d0295c32.tar.gz
gentoo-65af95dc8450cf07c64e2b5f9de34089d0295c32.tar.bz2
gentoo-65af95dc8450cf07c64e2b5f9de34089d0295c32.zip
net-libs/wandio: Initial commit (bug #592574).
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-libs/wandio/wandio-1.0.3.ebuild')
-rw-r--r--net-libs/wandio/wandio-1.0.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/wandio/wandio-1.0.3.ebuild b/net-libs/wandio/wandio-1.0.3.ebuild
new file mode 100644
index 000000000000..93ee50e43c5e
--- /dev/null
+++ b/net-libs/wandio/wandio-1.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Library for transparent file I/O with compression"
+HOMEPAGE="http://research.wand.net.nz/software/libwandio.php"
+SRC_URI="http://research.wand.net.nz/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 http lzma lzo static-libs zlib"
+
+RDEPEND="
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ http? ( net-misc/curl )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with bzip2) \
+ $(use_with http) \
+ $(use_with lzma) \
+ $(use_with lzo) \
+ $(use_with zlib)
+}